high CVSS 7.5 EPSS 0.79%

CVE-2025-49630·Apache vulnerability

In certain proxy configurations, a denial of service attack against Apache HTTP Server versions 2.4.26 through to 2.4.63 can be triggered by untrusted clients causing an assertion in mod_proxy_http2. Configurations affected are a reverse proxy is configured for an HTTP/2 backend, with ProxyPreserveHost set to "on".

Severity
high
Software
Apache
Fixed in
2.4.64
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.79% — higher than 74% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2025-49630 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.79%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 2.4.26

Until: 2.4.64

Fixed in: 2.4.64

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.64 or later to patch the assertion failure in mod_proxy_http2. This vulnerability specifically affects reverse proxy configurations with HTTP/2 backends and ProxyPreserveHost enabled, making it critical to update if your deployment matches this setup. Apply the update during a maintenance window and restart the Apache service to ensure the fix is active.

sudo dnf update httpd && sudo systemctl restart httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

GET|POST|HEAD|OPTIONS|CONNECT|TRACE|DELETE|PUT|PATCH requests originating from untrusted networks to a reverse proxy endpoint followed by Apache error log entries containing 'mod_proxy_http2', 'Assertion', or 'core:notice', with corresponding process termination (exit code 134 or 139)

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Configure rate limiting and connection limits on reverse proxy endpoints to reduce the impact of DoS attempts. Block or throttle requests from sources sending malformed HTTP/2 frames. Implement request timeout policies to prevent slowdown attacks. However, WAF rules cannot fully prevent this assertion-level vulnerability; upgrading Apache is mandatory.

How to check if you are affected

  1. Run 'apache2ctl -v' or 'httpd -v' to check the installed Apache version; versions 2.4.26 through 2.4.63 are vulnerable
  2. Check your Apache configuration file (typically /etc/apache2/sites-enabled/*.conf or /etc/httpd/conf.d/*.conf) for ProxyPreserveHost On combined with ProxyPass directives pointing to HTTP/2 backends
  3. Search Apache error logs (/var/log/apache2/error.log or /var/log/httpd/error_log) for assertion failures or segmentation faults from mod_proxy_http2 with patterns like 'Assertion.*failed' or 'SIGABRT'
  4. Verify the patch was applied by re-running 'apache2ctl -v' or 'httpd -v' and confirming the version is 2.4.64 or later, then check 'systemctl status apache2' or 'systemctl status httpd' shows the service is running

FAQ

What is CVE-2025-49630?

CVE-2025-49630 is a denial-of-service vulnerability in Apache HTTP Server's mod_proxy_http2 module that triggers an assertion failure when processing certain requests in reverse proxy configurations with HTTP/2 backends and ProxyPreserveHost enabled. Untrusted clients can exploit this to crash the Apache process.

Is CVE-2025-49630 being actively exploited?

No, CVE-2025-49630 is not listed in CISA's Known Exploited Vulnerabilities catalog and no public exploits are currently available. However, the attack requirements are low (network-accessible, no authentication needed), so timely patching is still strongly recommended.

What versions of Apache are affected by CVE-2025-49630?

Apache HTTP Server versions 2.4.26 through 2.4.63 are vulnerable. Version 2.4.64 and later contain the fix.

How do I check if my server is vulnerable to CVE-2025-49630?

Run 'apache2ctl -v' or 'httpd -v' to see your version; if it reports 2.4.26–2.4.63, you are vulnerable. Additionally, confirm your Apache config includes 'ProxyPreserveHost On' and at least one 'ProxyPass' directive pointing to an HTTP/2 backend using 'h2://' or 'h2c://' URIs.

Does Defensia detect CVE-2025-49630?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2025-49630 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-49630. Free for 1 server.

Get started free