critical CVSS 9.1 EPSS <0.1%

CVE-2025-23048·Apache vulnerability

In some mod_ssl configurations on Apache HTTP Server 2.4.35 through to 2.4.63, an access control bypass by trusted clients is possible using TLS 1.3 session resumption. Configurations are affected when mod_ssl is configured for multiple virtual hosts, with each restricted to a different set of trusted client certificates (for example with a different SSLCACertificateFile/Path setting). In such a case, a client trusted to access one virtual host may be able to access another virtual host, if SSLStrictSNIVHostCheck is not enabled in either virtual host.

Severity
critical
Software
Apache
Fixed in
2.4.64
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at <0.1% — higher than 9% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2025-23048 scores 9.1 on CVSS, so a successful attack would be serious — but at <0.1%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 2.4.35

Until: 2.4.64

Fixed in: 2.4.64

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.64 or later to patch the TLS 1.3 session resumption bypass. If you operate multiple virtual hosts with different client certificate restrictions, ensure SSLStrictSNIVHostCheck is enabled on all affected virtual hosts as an interim mitigation. Review your mod_ssl configuration to confirm each virtual host has distinct certificate validation policies properly enforced.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed Apache version: apache2ctl -v (on Debian/Ubuntu) or httpd -v (on RHEL/CentOS). Verify if version is between 2.4.35 and 2.4.63.
  2. Confirm mod_ssl is enabled: apache2ctl -M | grep ssl_module (Debian/Ubuntu) or httpd -M | grep ssl_module (RHEL/CentOS). If present, the vulnerability surface exists.
  3. Review Apache configuration for multiple virtual hosts with client certificate restrictions: grep -r 'SSLCACertificateFile\|SSLCACertificatePath\|SSLVerifyClient' /etc/apache2/sites-enabled/ (Ubuntu/Debian) or /etc/httpd/conf.d/ (RHEL/CentOS).
  4. Verify the fix by re-running apache2ctl -v or httpd -v after upgrade and confirming version is 2.4.64 or higher. Restart Apache: sudo systemctl restart apache2 (Debian/Ubuntu) or sudo systemctl restart httpd (RHEL/CentOS).

FAQ

What is CVE-2025-23048?

CVE-2025-23048 is a critical access control bypass in Apache mod_ssl that allows TLS 1.3 session resumption to authenticate a client to a different virtual host than originally intended. This occurs when multiple virtual hosts restrict client certificates differently and SSLStrictSNIVHostCheck is not enforced.

Is CVE-2025-23048 being actively exploited?

No, CVE-2025-23048 is not listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available. However, the critical CVSS score (9.1) warrants immediate patching.

What versions of Apache are affected by CVE-2025-23048?

Apache HTTP Server versions 2.4.35 through 2.4.63 are vulnerable. Version 2.4.64 and later include the fix.

How do I check if my server is vulnerable to CVE-2025-23048?

Run httpd -v or apache2ctl -v to check your version. If it reports 2.4.35–2.4.63 and mod_ssl is enabled (httpd -M | grep ssl_module), your server is vulnerable if you have multiple virtual hosts with different client certificate policies.

Does Defensia detect CVE-2025-23048?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2025-23048 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-23048. Free for 1 server.

Get started free