high CVSS 8.1 EPSS 88%

CVE-2024-38473·Apache vulnerability

Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Severity
high
Software
Apache
Fixed in
2.4.60
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 88% — in the top 0.5% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 2.4.0

Until: 2.4.60

Fixed in: 2.4.60

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.60 or later to resolve an encoding bypass vulnerability in mod_proxy that could allow authenticated attackers to circumvent backend authentication mechanisms. Prioritize this update for any deployment where mod_proxy forwards requests to backend services, as the vulnerability requires valid credentials but can lead to authentication bypass on downstream systems.

sudo dnf update httpd && sudo systemctl restart httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET /[a-zA-Z0-9/_-]*%(?:2e|2f|5c|3a)[a-zA-Z0-9/_-]* HTTP/1\.[01].*X-Forwarded-For|Proxy-Authorization

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement a WAF rule to block HTTP requests to proxy endpoints (e.g., paths handled by mod_proxy) that contain URL-encoded special characters (%, hex-encoded octets) in the path segment, particularly %2e, %2f, %5c, and %3a, while allowing legitimate encoded parameters in query strings only.

How to check if you are affected

  1. Run 'apache2ctl -v' or 'httpd -v' to check your current Apache version; if it reports 2.4.0 through 2.4.59, your installation is vulnerable
  2. Execute 'apache2ctl -M | grep proxy' (or 'httpd -M | grep proxy' on RHEL/CentOS) to confirm mod_proxy is loaded; if it appears, the vulnerable component is active
  3. Search your Apache access logs for requests containing URL-encoded characters followed by backend authentication failures: grep -i 'proxy.*%' /var/log/apache2/access.log | grep -i '401\|403'
  4. After applying the patch, re-run 'apache2ctl -v' to confirm version 2.4.60 or later is installed, then verify mod_proxy still loads and test a backend proxy request completes without encoding anomalies

FAQ

What is CVE-2024-38473?

CVE-2024-38473 is an encoding flaw in Apache mod_proxy that allows malformed or specially-crafted request URLs to bypass authentication validation rules on backend services, even when the frontend Apache server enforces authentication.

Is CVE-2024-38473 being actively exploited?

No, CVE-2024-38473 is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available; however, the high CVSS score (8.1) warrants prompt patching.

What versions of Apache are affected by CVE-2024-38473?

Apache HTTP Server versions 2.4.0 through 2.4.59 are vulnerable; version 2.4.60 and later contain the fix.

How do I check if my server is vulnerable to CVE-2024-38473?

Run 'apache2ctl -v' (or 'httpd -v' on Red Hat-based systems) and check if the version is between 2.4.0 and 2.4.59; if mod_proxy is also enabled (check with 'apache2ctl -M | grep proxy'), your setup is vulnerable.

Does Defensia detect CVE-2024-38473?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2024-38473 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-38473. Free for 1 server.

Get started free