critical CVSS 9.8 EPSS 3.5%

CVE-2024-38476·Apache vulnerability

Vulnerability in core of Apache HTTP Server 2.4.59 and earlier are vulnerably to information disclosure, SSRF or local script execution via backend applications whose response headers are malicious or exploitable. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Severity
critical
Software
Apache
Fixed in
2.4.60
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 3.5% — higher than 87% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 2.4.0

Until: 2.4.60

Fixed in: 2.4.60

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.60 or later immediately to patch a critical vulnerability that allows attackers to exploit malicious backend response headers for information disclosure, server-side request forgery, or code execution. Organizations running Apache 2.4.59 or earlier should prioritize this update as a critical security patch. After upgrading, validate the installation and restart the Apache service to ensure the fix is active.

sudo dnf update httpd httpd-core httpd-tools -y

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET .* HTTP/1.1.*\r\nX-.*:|Set-Cookie:.*exploit|Location:.*\$|Content-Disposition:.*exec|Transfer-Encoding:.*chunked.*\r\n0\r\n\r\n.*script

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement strict header validation rules that reject or sanitize response headers containing executable code patterns, script tags, or SSRF-indicative values. Block requests with malformed or oversized response headers. If using mod_proxy, apply rules to validate backend response headers before they are processed by the main Apache engine. Use ModSecurity with ruleset CRS to detect header injection attempts.

How to check if you are affected

  1. Run 'apache2 -v' or 'httpd -v' to check the installed Apache version; vulnerable if version is 2.4.0 through 2.4.59
  2. Check which Apache modules are enabled using 'apache2ctl -M' or 'httpctl -M' to understand potential attack vectors through proxy or backend integration
  3. Search Apache error and access logs for unusual response header patterns: grep -r 'malformed\|invalid\|exploit' /var/log/apache2/ or equivalent log directory
  4. After patching, verify the new version with 'apache2 -v' and confirm service restart was successful using 'systemctl status apache2' or 'service apache2 status'

FAQ

What is CVE-2024-38476?

CVE-2024-38476 is a critical vulnerability in Apache HTTP Server that allows attackers to craft malicious response headers from backend applications to trigger information disclosure, SSRF attacks, or arbitrary code execution on the web server. The vulnerability exists in how Apache processes and trusts untrusted backend response headers without proper sanitization.

Is CVE-2024-38476 being actively exploited?

According to CISA, CVE-2024-38476 is not currently listed in the Known Exploited Vulnerabilities (KEV) catalog and no public exploit code is available. However, the critical CVSS score of 9.8 warrants immediate patching regardless of active exploitation status.

What versions of Apache are affected by CVE-2024-38476?

All Apache HTTP Server versions from 2.4.0 through 2.4.59 are affected. Version 2.4.60 and later include the security fix.

How do I check if my server is vulnerable to CVE-2024-38476?

Run 'apache2 -v' or 'httpd -v' and check the version string; if it shows 2.4.59 or earlier, your server is vulnerable. Additionally, verify that mod_proxy or similar backend-handling modules are enabled with 'apache2ctl -M | grep proxy'.

Does Defensia detect CVE-2024-38476?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2024-38476 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-38476. Free for 1 server.

Get started free