critical CVSS 9.9 Actively exploited EPSS 97% Public exploit available

CVE-2025-49113·PHP vulnerability

Roundcube Webmail before 1.5.10 and 1.6.x before 1.6.11 allows remote code execution by authenticated users because the _from parameter in a URL is not validated in program/actions/settings/upload.php, leading to PHP Object Deserialization.

Severity
critical
Software
PHP
Fixed in
1.6.11
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 97% — in the top 0.1% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 1.6.0

Until: 1.6.11

Fixed in: 1.6.11

How to fix this CVE

Upgrade PHP and Roundcube Webmail immediately to version 1.6.11 or later to patch the unsafe deserialization vulnerability in the settings upload handler. This critical flaw allows authenticated attackers to execute arbitrary code by manipulating the _from parameter, bypassing input validation. Apply security updates across all affected servers without delay, as active exploitation has been confirmed.

sudo dnf update php php-common php-cli php-fpm -y

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST /roundcube/program/actions/settings/upload.php HTTP/1.1.*_from=.*O:[0-9]+:"[a-zA-Z_][a-zA-Z0-9_]*":[0-9]+:{

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Block or sanitize POST requests to */settings/upload.php that contain URL-encoded serialized PHP objects in the _from parameter (pattern: O:[0-9]+:). Implement strict input validation to reject any _from parameter values that are not valid email addresses.

How to check if you are affected

  1. Check installed PHP version: php -v | grep -oP 'PHP \K[0-9.]+'
  2. Verify Roundcube version: grep -i 'RCMAIL_VERSION\|rcmail_version' /path/to/roundcube/program/include/iniset.php
  3. Search web server logs for POST requests to settings/upload.php with suspicious _from parameters: grep -i 'settings/upload.php' /var/log/apache2/access.log /var/log/nginx/access.log | grep '_from='
  4. Confirm patch applied: php -r "echo phpversion();" and verify against 1.6.11+ release notes

Indicators of compromise

  • POST requests to settings/upload.php with _from parameter containing 'O:' (PHP object serialization marker)
  • Roundcube process spawning unexpected child processes or shell commands
  • Unusual file creation or modification in Roundcube temporary directories (/tmp/roundcube*, /var/tmp)

FAQ

What is CVE-2025-49113?

A critical remote code execution vulnerability in Roundcube Webmail's settings upload handler that deserializes untrusted PHP objects when processing the _from parameter, allowing authenticated users to execute arbitrary code on the server.

Is CVE-2025-49113 being actively exploited?

Yes, this vulnerability is actively exploited in the wild and has been added to the CISA Known Exploited Vulnerabilities (KEV) catalog. Public exploits are available, making immediate patching critical.

What versions of PHP are affected by CVE-2025-49113?

Roundcube Webmail versions 1.6.0 through 1.6.10 are vulnerable. Version 1.6.11 and later contain the necessary patches. Earlier versions (1.5.9 and below) are also unaffected.

How do I check if my server is vulnerable to CVE-2025-49113?

Run: grep -r 'RCMAIL_VERSION' /path/to/roundcube/program/ and check if the version is between 1.6.0-1.6.10. Additionally, verify that program/actions/settings/upload.php has not been patched by checking for input validation on the _from parameter.

Does Defensia detect CVE-2025-49113?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PHP and Roundcube are installed on a monitored server, CVE-2025-49113 will appear in your dashboard with remediation steps.

Related PHP CVEs

CVE-2026-39337CVSS 10ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.
CVE-2024-5932CVSS 10The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.14.1 via deserialization of untrusted input from the 'give_title' parameter. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code remotely, and to delete arbitrary files.
CVE-2025-47916CVSS 10Invision Community 5.0.0 before 5.0.7 allows remote code execution via crafted template strings to themeeditor.php. The issue lies within the themeeditor controller (file: /applications/core/modules/front/system/themeeditor.php), where a protected method named customCss can be invoked by unauthenticated users. This method passes the value of the content parameter to the Theme::makeProcessFunction() method; hence it is evaluated by the template engine. Accordingly, this can be exploited by unauthenticated attackers to inject and execute arbitrary PHP code by providing crafted template strings.
CVE-2025-25174CVSS 10Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in beeteam368 BeeTeam368 Extensions beeteam368-extensions allows PHP Local File Inclusion.This issue affects BeeTeam368 Extensions: from n/a through <= 1.9.4.
CVE-2025-46348CVSS 10YesWiki is a wiki system written in PHP. Prior to version 4.5.4, the request to commence a site backup can be performed and downloaded without authentication. The archives are created with a predictable filename, so a malicious user could create and download an archive without being authenticated. This could result in a malicious attacker making numerous requests to create archives and fill up the file system, or by downloading the archive which contains sensitive site information. This issue has been patched in version 4.5.4.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-49113. Free for 1 server.

Get started free