critical CVSS 9.8 EPSS 1.0%

CVE-2025-0493·PHP vulnerability

The MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution plugin for WordPress is vulnerable to Limited Local File Inclusion in all versions up to, and including, 4.2.14 via the tabname parameter. This makes it possible for unauthenticated attackers to include PHP files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where PHP files can be uploaded and included

Severity
critical
Software
PHP
Fixed in
4.2.15
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.0% — higher than 59% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 4.2.15

Fixed in: 4.2.15

How to fix this CVE

Update the MultiVendorX WooCommerce plugin to version 4.2.15 or later to patch the local file inclusion vulnerability in the tabname parameter. If you cannot update immediately, disable the plugin and review your server logs for suspicious file inclusion attempts. Organizations running vulnerable versions should prioritize this update to prevent unauthorized PHP code execution.

sudo dnf upgrade php php-common php-curl php-mbstring php-xml

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET request to wp-admin/admin-ajax.php with parameters containing 'action=' followed by MultiVendorX AJAX handlers and 'tabname=' containing PHP file paths (e.g., 'tabname=../../../wp-config.php' or 'tabname=../wp-load.php')

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement WAF rules to block requests to wp-admin/admin-ajax.php with tabname parameters containing directory traversal sequences (../, ..\ or PHP stream wrappers like php://, file://). Whitelist only expected tabname values specific to the plugin's legitimate functionality and enforce strict input validation rejecting any path components.

How to check if you are affected

  1. Check installed MultiVendorX plugin version: Log into WordPress admin, navigate to Plugins > Installed Plugins, and note the version number next to 'MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution'
  2. Verify the vulnerable component is active: Confirm the plugin is enabled and the tabname AJAX parameter is accessible by checking if dc-woocommerce-multi-vendor/classes/class-mvx-ajax.php is loaded (check wp-config.php debug logs or use curl to test AJAX endpoints)
  3. Search web server logs for exploitation attempts: grep -i 'tabname' /var/log/apache2/access.log /var/log/nginx/access.log | grep -i 'include\|require\|php\|\.\./' to identify suspicious parameter usage
  4. Confirm the patch is applied: Verify the plugin version is 4.2.15 or later in WordPress admin; cross-reference with the changelog at https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.15

FAQ

What is CVE-2025-0493?

CVE-2025-0493 is a critical local file inclusion vulnerability in the MultiVendorX WordPress plugin affecting versions up to 4.2.14. The flaw allows unauthenticated attackers to manipulate the tabname parameter in an AJAX endpoint to include and execute arbitrary PHP files on the server, potentially leading to full site compromise.

Is CVE-2025-0493 being actively exploited?

No, CVE-2025-0493 is not currently listed on the CISA KEV catalog and no public exploits have been reported. However, the critical CVSS 9.8 score and unauthenticated attack vector mean it should be treated as a high priority for immediate patching.

What versions of the MultiVendorX plugin are affected by CVE-2025-0493?

All versions of the MultiVendorX plugin up to and including version 4.2.14 are vulnerable. The vulnerability has been patched in version 4.2.15 and later.

How do I check if my WordPress site is vulnerable to CVE-2025-0493?

Log into your WordPress admin dashboard, navigate to Plugins > Installed Plugins, and locate 'MultiVendorX.' If the version number is 4.2.14 or earlier, your site is vulnerable. Immediately update to version 4.2.15 or later.

Does Defensia detect CVE-2025-0493?

Yes — Defensia's CVE advisory scanner identifies WordPress plugin versions against the NVD vulnerability database. If the MultiVendorX plugin is installed on a monitored WordPress site, CVE-2025-0493 will appear in your dashboard with direct remediation steps and update links.

Related PHP CVEs

CVE-2025-47916CVSS 10Invision Community 5.0.0 before 5.0.7 allows remote code execution via crafted template strings to themeeditor.php. The issue lies within the themeeditor controller (file: /applications/core/modules/front/system/themeeditor.php), where a protected method named customCss can be invoked by unauthenticated users. This method passes the value of the content parameter to the Theme::makeProcessFunction() method; hence it is evaluated by the template engine. Accordingly, this can be exploited by unauthenticated attackers to inject and execute arbitrary PHP code by providing crafted template strings.
CVE-2026-39337CVSS 10ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.
CVE-2025-25174CVSS 10Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in beeteam368 BeeTeam368 Extensions beeteam368-extensions allows PHP Local File Inclusion.This issue affects BeeTeam368 Extensions: from n/a through <= 1.9.4.
CVE-2024-5932CVSS 10The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.14.1 via deserialization of untrusted input from the 'give_title' parameter. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code remotely, and to delete arbitrary files.
CVE-2026-28289CVSS 10FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. A patch bypass vulnerability for CVE-2026-27636 in FreeScout 1.8.206 and earlier allows any authenticated user with file upload permissions to achieve Remote Code Execution (RCE) on the server by uploading a malicious .htaccess file using a zero-width space character prefix to bypass the security check. The vulnerability exists in the sanitizeUploadedFileName() function in app/Http/Helper.php. The function contains a Time-of-Check to Time-of-Use (TOCTOU) flaw where the dot-prefix check occurs before sanitization removes invisible characters. This vulnerability is fixed in 1.8.207.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-0493. Free for 1 server.

Get started free