critical CVSS 9.8 EPSS 4.8%

CVE-2024-6460·PHP vulnerability

The Grow by Tradedoubler WordPress plugin through 2.0.21 is vulnerable to Local File Inclusion via the component parameter. This makes it possible for attackers to include and execute PHP files on the server, allowing the execution of any PHP code in those files.

Severity
critical
Software
PHP
Fixed in
2.0.22
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 4.8% — in the top 9% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.0.22

Fixed in: 2.0.22

How to fix this CVE

Update the Grow by Tradedoubler WordPress plugin to version 2.0.22 or later to eliminate the local file inclusion vulnerability in the component parameter. This patch prevents attackers from leveraging path traversal techniques to access and execute arbitrary PHP files on your server. Apply the update immediately through your WordPress plugin management interface or via command line.

sudo dnf update php php-common php-cli

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET /wp-admin/admin-ajax.php.*component=.*(\.\./|%2e%2e|php:|file:|phar:)

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement WAF rules to block requests containing the 'component' parameter with path traversal sequences (../, %2e%2e, encoded dots) or protocol handlers (file:, php:, phar:). Example: Block requests matching pattern: /wp-admin/admin-ajax.php.*component.*[./]{2,}|component.*(file:|php:|phar:)

How to check if you are affected

  1. Check installed WordPress plugin version: grep 'Version:' /var/www/html/wp-content/plugins/grow-by-tradedoubler/grow-by-tradedoubler.php
  2. Verify the plugin's main file exists and examine it for vulnerable component parameter handling: find /var/www/html/wp-content/plugins/grow-by-tradedoubler -name '*.php' | head -1
  3. Search web server logs for exploitation attempts using the component parameter: grep -i 'component=' /var/log/apache2/access.log | grep -E '(\.\./|%2e%2e|php:|file:)'
  4. Confirm the plugin has been updated to 2.0.22 or later: curl -s https://api.wordpress.org/plugins/info/1.0/grow-by-tradedoubler.json | grep version

FAQ

What is CVE-2024-6460?

CVE-2024-6460 is a critical local file inclusion (LFI) vulnerability in the Grow by Tradedoubler WordPress plugin that allows remote attackers to execute arbitrary PHP code by manipulating the component parameter. The vulnerability has a CVSS score of 9.8, indicating severe impact on confidentiality, integrity, and availability.

Is CVE-2024-6460 being actively exploited?

Currently, CVE-2024-6460 is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, and no public exploits are available. However, the critical severity and ease of exploitation mean deployment of version 2.0.22 should be treated as urgent.

What versions of the Grow by Tradedoubler plugin are affected by CVE-2024-6460?

All versions of the Grow by Tradedoubler WordPress plugin through version 2.0.21 are vulnerable. Version 2.0.22 and later contain the security fix.

How do I check if my server is vulnerable to CVE-2024-6460?

Run: grep 'Version:' /var/www/html/wp-content/plugins/grow-by-tradedoubler/grow-by-tradedoubler.php and compare the version number against 2.0.22. If the installed version is 2.0.21 or earlier, your site is vulnerable.

Does Defensia detect CVE-2024-6460?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If the Grow by Tradedoubler WordPress plugin is detected on a monitored server with version 2.0.21 or earlier, CVE-2024-6460 will appear in your dashboard with remediation steps.

Related PHP CVEs

CVE-2026-28289CVSS 10FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. A patch bypass vulnerability for CVE-2026-27636 in FreeScout 1.8.206 and earlier allows any authenticated user with file upload permissions to achieve Remote Code Execution (RCE) on the server by uploading a malicious .htaccess file using a zero-width space character prefix to bypass the security check. The vulnerability exists in the sanitizeUploadedFileName() function in app/Http/Helper.php. The function contains a Time-of-Check to Time-of-Use (TOCTOU) flaw where the dot-prefix check occurs before sanitization removes invisible characters. This vulnerability is fixed in 1.8.207.
CVE-2025-47916CVSS 10Invision Community 5.0.0 before 5.0.7 allows remote code execution via crafted template strings to themeeditor.php. The issue lies within the themeeditor controller (file: /applications/core/modules/front/system/themeeditor.php), where a protected method named customCss can be invoked by unauthenticated users. This method passes the value of the content parameter to the Theme::makeProcessFunction() method; hence it is evaluated by the template engine. Accordingly, this can be exploited by unauthenticated attackers to inject and execute arbitrary PHP code by providing crafted template strings.
CVE-2025-62521CVSS 10ChurchCRM is an open-source church management system. Prior to version 5.21.0, a pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The vulnerability exists in `setup/routes/setup.php` where user input from the setup form is directly concatenated into a PHP configuration template without any validation or sanitization. Any parameter in the setup form can be used to inject PHP code that gets written to `Include/Config.php`, which is then executed on every page load. This is more severe than typical authenticated RCE vulnerabilities because it requires no credentials and affects the installation process that administrators must complete. Version 5.21.0 patches the issue.
CVE-2026-39337CVSS 10ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.
CVE-2025-25174CVSS 10Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in beeteam368 BeeTeam368 Extensions beeteam368-extensions allows PHP Local File Inclusion.This issue affects BeeTeam368 Extensions: from n/a through <= 1.9.4.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-6460. Free for 1 server.

Get started free