high CVSS 7.5 EPSS 0.23%

CVE-2024-43204·Apache vulnerability

SSRF in Apache HTTP Server with mod_proxy loaded allows an attacker to send outbound proxy requests to a URL controlled by the attacker.  Requires an unlikely configuration where mod_headers is configured to modify the Content-Type request or response header with a value provided in the HTTP request. Users are recommended to upgrade to version 2.4.64 which fixes this issue.

Severity
high
Software
Apache
Fixed in
2.4.64
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.23% — higher than 45% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2024-43204 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.23%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 2.4.0

Until: 2.4.64

Fixed in: 2.4.64

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.64 or later to address this Server-Side Request Forgery (SSRF) vulnerability. Organizations running Apache with mod_proxy enabled should prioritize this update, particularly if mod_headers is configured to process user-controlled Content-Type headers. This vulnerability allows attackers to manipulate proxy requests to reach internal or external targets when specific header configurations are present.

sudo dnf update httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

GET|POST|HEAD request with crafted Content-Type header containing external URLs (e.g., http:// or https://) followed by proxy response status codes (200, 301, 302) to non-standard ports; regex: (Content-Type:.*http[s]?://[^\s]+|X-Forwarded-.*http[s]?://[^\s]+)

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Configure WAF rules to block HTTP requests with suspicious Content-Type or X-Forwarded-* headers containing URL schemes (http://, https://, ftp://). Implement strict header validation to reject requests where these headers contain values other than standard MIME types. Restrict access to proxy endpoints to trusted internal networks only.

How to check if you are affected

  1. Step 1: Check Apache version by running: apache2ctl -v (Ubuntu/Debian) or httpd -v (RHEL/CentOS). Compare against 2.4.64 — versions below this are vulnerable.
  2. Step 2: Verify if mod_proxy is loaded: grep -i 'mod_proxy' /etc/apache2/mods-enabled/*.conf (Ubuntu/Debian) or /etc/httpd/modules/ (RHEL/CentOS). If present and mod_headers is also enabled, your configuration is at risk.
  3. Step 3: Search Apache access and error logs for unusual outbound proxy requests: grep -i 'proxy' /var/log/apache2/access.log | grep -E '(http://|https://)' to identify potential exploitation attempts.
  4. Step 4: After upgrading, confirm the version: apache2ctl -v or httpd -v should display 2.4.64 or higher, and restart Apache with: sudo systemctl restart apache2 (Ubuntu/Debian) or sudo systemctl restart httpd (RHEL/CentOS).

FAQ

What is CVE-2024-43204?

CVE-2024-43204 is a Server-Side Request Forgery (SSRF) vulnerability in Apache HTTP Server that occurs when mod_proxy is loaded and mod_headers is configured to process user-supplied Content-Type headers. An attacker can inject malicious header values to force the proxy to make outbound requests to attacker-controlled URLs, potentially bypassing network controls.

Is CVE-2024-43204 being actively exploited?

No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities (KEV) catalog, and no public exploits are available. However, organizations should still prioritize patching due to the high CVSS score of 7.5 and the integrity impact it poses.

What versions of Apache are affected by CVE-2024-43204?

Apache HTTP Server versions 2.4.0 through 2.4.63 are vulnerable. Version 2.4.64 and later contain the fix.

How do I check if my server is vulnerable to CVE-2024-43204?

Run 'apache2ctl -v' or 'httpd -v' to check your version. If it shows 2.4.63 or earlier, you are vulnerable. Additionally, check if both mod_proxy and mod_headers are enabled with 'apachectl -M' to confirm exposure risk.

Does Defensia detect CVE-2024-43204?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2024-43204 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-43204. Free for 1 server.

Get started free