high CVSS 7.5 EPSS 0.31%

CVE-2024-42516·Apache vulnerability

HTTP response splitting in the core of Apache HTTP Server allows an attacker who can manipulate the Content-Type response headers of applications hosted or proxied by the server can split the HTTP response. This vulnerability was described as CVE-2023-38709 but the patch included in Apache HTTP Server 2.4.59 did not address the issue. Users are recommended to upgrade to version 2.4.64, which fixes this issue.

Severity
high
Software
Apache
Fixed in
2.4.64
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.31% — higher than 54% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2024-42516 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.31%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 2.4.0

Until: 2.4.64

Fixed in: 2.4.64

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.64 or later to patch a response-splitting vulnerability that could allow attackers to inject malicious HTTP headers. Organizations running versions 2.4.0 through 2.4.63 should prioritize this update, particularly if the server processes user-controlled or application-provided Content-Type headers. This vulnerability was initially addressed in 2.4.59 but the fix was incomplete, making 2.4.64 the first fully patched release.

sudo dnf update httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET .* HTTP/1\.1\r\nContent-Type:[^\r]*(%0d|%0a|\r|\n)+[A-Za-z-]+:|^[^\r]*\r\n\r\n[A-Za-z-]+: [^\r]*\r\n

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement a WAF rule to block HTTP requests with CRLF sequences (%0d, %0a, \r, \n) in the Content-Type header or any response header fields. Additionally, reject requests with malformed or duplicate Content-Type headers that could be used to inject response data.

How to check if you are affected

  1. Check installed Apache version: apache2ctl -v (Ubuntu/Debian) or httpd -v (RHEL/CentOS/Amazon Linux)
  2. Verify the server is exposed to untrusted client connections by checking firewall rules and virtual host configurations: grep -r 'VirtualHost' /etc/apache2/sites-enabled/ or /etc/httpd/conf/
  3. Search Apache access and error logs for suspicious Content-Type header patterns or CRLF injection attempts: grep -E '(%0d|%0a|\r|\n)' /var/log/apache2/access.log* or /var/log/httpd/access_log*
  4. Confirm the patched version is running after upgrade: apache2ctl -v or httpd -v (should show 2.4.64 or higher)

FAQ

What is CVE-2024-42516?

CVE-2024-42516 is an HTTP response-splitting vulnerability in Apache HTTP Server that occurs when an attacker manipulates Content-Type response headers to inject additional HTTP headers or split the HTTP response. This can lead to cache poisoning, session hijacking, or cross-site scripting attacks.

Is CVE-2024-42516 being actively exploited?

No, CVE-2024-42516 is not currently listed as actively exploited in the CISA KEV catalog, and no public exploits are documented. However, its high CVSS score of 7.5 and the ease of crafting Content-Type headers make proactive patching essential.

What versions of Apache are affected by CVE-2024-42516?

All versions from Apache HTTP Server 2.4.0 through 2.4.63 are vulnerable. Version 2.4.64 and later contain the fix.

How do I check if my server is vulnerable to CVE-2024-42516?

Run 'httpd -v' or 'apache2ctl -v' to display the installed version. If the output shows version 2.4.0 through 2.4.63, your server is vulnerable and requires immediate upgrade to 2.4.64 or later.

Does Defensia detect CVE-2024-42516?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2024-42516 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-42516. Free for 1 server.

Get started free