high CVSS 7.5 EPSS 0.47%

CVE-2024-40898·Apache vulnerability

SSRF in Apache HTTP Server on Windows with mod_rewrite in server/vhost context, allows to potentially leak NTML hashes to a malicious server via SSRF and malicious requests. Users are recommended to upgrade to version 2.4.62 which fixes this issue. 

Severity
high
Software
Apache
Fixed in
2.4.62
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.47% — higher than 64% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2024-40898 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.47%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 2.4.62

Fixed in: 2.4.62

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.62 or later to address this server-side request forgery vulnerability affecting Windows deployments with mod_rewrite. Organizations running Apache on Windows should prioritize this update to prevent potential credential leakage through malicious rewrite rules that could redirect internal requests to attacker-controlled servers.

sudo dnf update httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET|HEAD requests containing unusual 'Host:' headers pointing to internal IP ranges (127.0.0.1, 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16) combined with mod_rewrite rule triggers; alternatively, log entries showing 'mod_rewrite' rules redirecting to external URLs with NTLM authentication headers

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement WAF rules to block requests with rewrite-triggering patterns that attempt to redirect traffic to private IP ranges or external hosts not in an allowlist. Restrict mod_rewrite directives in .htaccess files and enforce strict input validation on parameters that feed into rewrite rules.

How to check if you are affected

  1. Step 1: Check Apache version with 'apache2 -v' (Debian/Ubuntu) or 'httpd -v' (RHEL/CentOS) and confirm it is below 2.4.62
  2. Step 2: Verify mod_rewrite is enabled by running 'apache2ctl -M | grep rewrite' or 'httpctl -M | grep rewrite' and check for rewrite rules in server or vhost context
  3. Step 3: Search Apache access and error logs for suspicious external requests or failed connection attempts: 'grep -E "CONNECT|tunnel|proxy" /var/log/apache2/error.log'
  4. Step 4: After patching, run 'apache2ctl -v' or 'httpctl -v' to confirm version is 2.4.62 or higher, then restart the service with 'sudo systemctl restart apache2' or 'sudo systemctl restart httpd'

FAQ

What is CVE-2024-40898?

This vulnerability is a server-side request forgery (SSRF) flaw in Apache HTTP Server running on Windows systems with mod_rewrite enabled in server or vhost configuration contexts. An attacker can craft malicious rewrite rules to force the server to make requests to arbitrary destinations, potentially exposing sensitive credentials like NTLM hashes.

Is CVE-2024-40898 being actively exploited?

No, this vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities (KEV) catalog, and no public exploits have been disclosed as of the advisory date.

What versions of Apache are affected by CVE-2024-40898?

All Apache HTTP Server versions prior to 2.4.62 are potentially affected, particularly those deployed on Windows systems with mod_rewrite active in server or virtual host contexts.

How do I check if my server is vulnerable to CVE-2024-40898?

Run 'apache2 -v' or 'httpd -v' to identify your version; if it returns a version lower than 2.4.62, then verify mod_rewrite is enabled with 'apache2ctl -M | grep rewrite'. If both conditions are true and you are on Windows, your system is vulnerable.

Does Defensia detect CVE-2024-40898?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2024-40898 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-40898. Free for 1 server.

Get started free