high CVSS 7.5 EPSS 3.2%

CVE-2024-39573·Apache vulnerability

Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Severity
high
Software
Apache
Fixed in
2.4.60
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 3.2% — higher than 87% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 2.4.0

Until: 2.4.60

Fixed in: 2.4.60

How to fix this CVE

Apache HTTP Server 2.4.59 and earlier contain a flaw in mod_rewrite that can allow attackers to manipulate URL rewriting rules to route requests through mod_proxy unexpectedly, creating a server-side request forgery (SSRF) pathway. Upgrade to Apache 2.4.60 or later to resolve this vulnerability. Review your RewriteRules configuration to ensure they do not inadvertently enable proxy access to internal or restricted resources.

sudo dnf update httpd

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET request containing encoded or unencoded rewrite rule parameters that include 'mod_proxy', '[P]' flag, or 'ProxyPassReverse' directives in the URI path or Host header, particularly targeting internal IP addresses or localhost endpoints

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement WAF rules to block HTTP requests containing rewrite rule syntax patterns in user input (e.g., regex patterns matching '\[P\]|ProxyPass|mod_proxy' in query strings and request headers). Additionally, restrict outbound proxy requests from the web application to only explicitly whitelisted internal endpoints.

How to check if you are affected

  1. Step 1: Check your Apache version with 'apache2ctl -v' or 'httpd -v' and verify it is 2.4.60 or later
  2. Step 2: Examine your Apache configuration files (typically /etc/apache2/apache2.conf or /etc/httpd/conf/httpd.conf) for RewriteRule directives that reference [P] proxy flag or RewriteCond rules that might route to mod_proxy
  3. Step 3: Search Apache access and error logs for unusual proxy requests, particularly those targeting internal IP ranges (10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16) or localhost: 'grep -i "mod_proxy\|\[P\]" /var/log/apache2/access.log /var/log/apache2/error.log'
  4. Step 4: After upgrading, confirm the new version with 'apache2ctl -v' or 'httpd -v' and restart the service: 'sudo systemctl restart apache2' or 'sudo systemctl restart httpd'

FAQ

What is CVE-2024-39573?

CVE-2024-39573 is a server-side request forgery (SSRF) vulnerability in Apache's mod_rewrite module that allows attackers to bypass security controls by crafting malicious URLs that exploit unsafe rewrite rules to reach internal resources via mod_proxy, potentially bypassing access restrictions and exposing sensitive internal services.

Is CVE-2024-39573 being actively exploited?

No, CVE-2024-39573 is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available, though organizations should still prioritize patching to prevent future exploitation.

What versions of Apache are affected by CVE-2024-39573?

Apache HTTP Server versions 2.4.0 through 2.4.59 are vulnerable; version 2.4.60 and later contain the fix.

How do I check if my server is vulnerable to CVE-2024-39573?

Run 'apache2ctl -v' or 'httpd -v' to display your Apache version. If it shows 2.4.59 or earlier, your server is vulnerable and requires immediate updating to 2.4.60 or later.

Does Defensia detect CVE-2024-39573?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2024-39573 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-39573. Free for 1 server.

Get started free