high CVSS 7.5 EPSS 1.4%

CVE-2024-38477·Apache vulnerability

null pointer dereference in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows an attacker to crash the server via a malicious request. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Severity
high
Software
Apache
Fixed in
2.4.60
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.4% — higher than 80% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 2.4.0

Until: 2.4.60

Fixed in: 2.4.60

How to fix this CVE

Apache HTTP Server versions 2.4.59 and earlier contain a null pointer dereference vulnerability in the mod_proxy module that can be triggered by specially crafted requests, leading to service denial. Immediately upgrade to Apache 2.4.60 or later to patch this flaw. If immediate patching is not feasible, disable the mod_proxy module or restrict access to affected proxy endpoints using firewall rules.

sudo dnf update httpd httpd-tools

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check installed Apache version with 'apache2ctl -v' or 'httpd -v' and confirm it is 2.4.60 or later
  2. Step 2: Verify mod_proxy is enabled by running 'apache2ctl -M | grep proxy' and note if proxy_module is loaded
  3. Step 3: Search Apache error logs for segmentation faults or crashes: 'grep -i "segmentation\|seg fault\|null pointer" /var/log/apache2/error.log'
  4. Step 4: After patching, restart Apache with 'sudo systemctl restart apache2' and confirm it stays running for at least 5 minutes under normal load

FAQ

What is CVE-2024-38477?

This vulnerability is a null pointer dereference in Apache's mod_proxy module that occurs when processing malformed proxy requests. An unauthenticated attacker can send a specially crafted HTTP request to cause the Apache process to crash, resulting in denial of service.

Is CVE-2024-38477 being actively exploited?

No, according to CISA's Known Exploited Vulnerabilities catalog, this CVE is not currently being exploited in the wild. However, proof-of-concept information is publicly available, so patching should not be delayed.

What versions of Apache are affected by CVE-2024-38477?

Apache HTTP Server versions 2.4.0 through 2.4.59 are vulnerable. Version 2.4.60 and later include the fix.

How do I check if my server is vulnerable to CVE-2024-38477?

Run 'apache2ctl -v' or 'httpd -v' to display your Apache version. If it shows 2.4.59 or earlier and 'apache2ctl -M | grep proxy_module' returns a match, your server is vulnerable.

Does Defensia detect CVE-2024-38477?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2024-38477 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-38477. Free for 1 server.

Get started free