high CVSS 7.5 EPSS 90%

CVE-2024-38472·Apache vulnerability

SSRF in Apache HTTP Server on Windows allows to potentially leak NTLM hashes to a malicious server via SSRF and malicious requests or content Users are recommended to upgrade to version 2.4.60 which fixes this issue.  Note: Existing configurations that access UNC paths will have to configure new directive "UNCList" to allow access during request processing.

Severity
high
Software
Apache
Fixed in
2.4.60
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 90% — in the top 0.4% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 2.4.0

Until: 2.4.60

Fixed in: 2.4.60

How to fix this CVE

Upgrade Apache HTTP Server to version 2.4.60 or later to patch this Server-Side Request Forgery (SSRF) vulnerability on Windows systems. If your configuration uses UNC paths, you must configure the new 'UNCList' directive to maintain access to those resources after upgrading. Test the upgrade in a staging environment first to ensure compatibility with your existing directives and network policies.

sudo dnf update httpd

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed Apache version with: apache2ctl -v (Ubuntu/Debian) or httpd -v (RHEL/CentOS)
  2. Verify if your Apache is running on Windows by checking the platform in the version output and reviewing your system OS
  3. Search Apache access and error logs for suspicious UNC path requests or unusual outbound connections: grep -i 'unc\|\\\\' /var/log/apache2/access.log
  4. After patching, confirm version with apache2ctl -v or httpd -v and verify the UNCList directive is properly configured if you use UNC paths

FAQ

What is CVE-2024-38472?

CVE-2024-38472 is a Server-Side Request Forgery (SSRF) vulnerability in Apache HTTP Server on Windows that allows attackers to trigger NTLM hash leakage by crafting malicious requests that force the server to authenticate to an attacker-controlled SMB server.

Is CVE-2024-38472 being actively exploited?

No, CVE-2024-38472 is not listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available, though the vulnerability has been disclosed.

What versions of Apache are affected by CVE-2024-38472?

Apache HTTP Server versions 2.4.0 through 2.4.59 are vulnerable. Version 2.4.60 and later contain the fix.

How do I check if my server is vulnerable to CVE-2024-38472?

Run httpd -v or apache2ctl -v and check the version number. If it shows 2.4.59 or earlier AND the server is running on Windows, your installation is vulnerable.

Does Defensia detect CVE-2024-38472?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache is installed on a monitored server, CVE-2024-38472 will appear in your dashboard with remediation steps.

Related Apache CVEs

CVE-2021-41773CVSS 10A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.
CVE-2021-42013CVSS 10It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.
CVE-2026-44631CVSS 10Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2026-29167CVSS 10Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.
CVE-2021-44790CVSS 10A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-38472. Free for 1 server.

Get started free