critical CVSS 9.8 EPSS 0.88%

CVE-2024-12562·PHP vulnerability

The s2Member Pro plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 241216 via deserialization of untrusted input from the 's2member_pro_remote_op' vulnerable parameter. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

Severity
critical
Software
PHP
Fixed in
250214
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.88% — higher than 55% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2024-12562 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.88%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 250214

Fixed in: 250214

How to fix this CVE

Update the s2Member Pro WordPress plugin to version 250214 or later to patch the PHP Object Injection vulnerability in the 's2member_pro_remote_op' parameter. This vulnerability allows unauthenticated attackers to inject malicious PHP objects that could lead to arbitrary file deletion, data theft, or code execution if additional POP chains exist on your system. Immediately apply the update and verify no suspicious activity occurred during the exposure window.

sudo dnf check-update php && sudo dnf upgrade php

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST.*s2member_pro_remote_op.*O:[0-9]+:"[a-zA-Z_\\]+":[0-9]+:{

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Block or rate-limit POST requests to WordPress admin-ajax.php containing the 's2member_pro_remote_op' parameter combined with serialized PHP object patterns (strings starting with 'O:' or 'C:' followed by class name and object structure). Consider implementing strict input validation rules that reject serialized data in this parameter.

How to check if you are affected

  1. Step 1: Check PHP version with `php -v` and verify the installed version is 7.4+ (required for s2Member Pro)
  2. Step 2: List installed WordPress plugins with `wp plugin list --path=/var/www/html` (replace path as needed) and confirm s2Member Pro version is below 250214
  3. Step 3: Search WordPress error and access logs for POST requests containing 's2member_pro_remote_op' parameter: `grep -r 's2member_pro_remote_op' /var/log/apache2/ /var/log/nginx/`
  4. Step 4: After updating, verify the plugin version with `wp plugin get s2-member-pro --field=version` and confirm it shows 250214 or higher

FAQ

What is CVE-2024-12562?

CVE-2024-12562 is a critical PHP Object Injection vulnerability in s2Member Pro that allows unauthenticated attackers to deserialize untrusted input via the 's2member_pro_remote_op' parameter, potentially enabling remote code execution or data exfiltration if POP chains are available on the target system.

Is CVE-2024-12562 being actively exploited?

No, this vulnerability is not currently listed in the CISA Known Exploited Vulnerabilities catalog, and no public exploits are available. However, the critical CVSS score of 9.8 and unauthenticated attack vector make immediate patching essential.

What versions of PHP are affected by CVE-2024-12562?

CVE-2024-12562 affects s2Member Pro plugin versions up to and including 241216; the vulnerability was resolved in version 250214. The underlying PHP deserialization issue impacts all PHP versions running the vulnerable plugin.

How do I check if my server is vulnerable to CVE-2024-12562?

Run `wp plugin get s2-member-pro --field=version` on your WordPress installation to retrieve the s2Member Pro version. If it returns a version number up to 241216, your system is vulnerable. Update immediately to 250214 or later.

Does Defensia detect CVE-2024-12562?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If s2Member Pro is installed on a monitored WordPress server, CVE-2024-12562 will appear in your dashboard with remediation steps.

Related PHP CVEs

CVE-2025-47916CVSS 10Invision Community 5.0.0 before 5.0.7 allows remote code execution via crafted template strings to themeeditor.php. The issue lies within the themeeditor controller (file: /applications/core/modules/front/system/themeeditor.php), where a protected method named customCss can be invoked by unauthenticated users. This method passes the value of the content parameter to the Theme::makeProcessFunction() method; hence it is evaluated by the template engine. Accordingly, this can be exploited by unauthenticated attackers to inject and execute arbitrary PHP code by providing crafted template strings.
CVE-2026-39337CVSS 10ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.
CVE-2025-25174CVSS 10Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in beeteam368 BeeTeam368 Extensions beeteam368-extensions allows PHP Local File Inclusion.This issue affects BeeTeam368 Extensions: from n/a through <= 1.9.4.
CVE-2024-5932CVSS 10The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.14.1 via deserialization of untrusted input from the 'give_title' parameter. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code remotely, and to delete arbitrary files.
CVE-2026-28289CVSS 10FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. A patch bypass vulnerability for CVE-2026-27636 in FreeScout 1.8.206 and earlier allows any authenticated user with file upload permissions to achieve Remote Code Execution (RCE) on the server by uploading a malicious .htaccess file using a zero-width space character prefix to bypass the security check. The vulnerability exists in the sanitizeUploadedFileName() function in app/Http/Helper.php. The function contains a Time-of-Check to Time-of-Use (TOCTOU) flaw where the dot-prefix check occurs before sanitization removes invisible characters. This vulnerability is fixed in 1.8.207.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-12562. Free for 1 server.

Get started free