critical CVSS 9.8 EPSS 1.0%

CVE-2018-25270·PHP vulnerability

ThinkPHP 5.0.23 contains a remote code execution vulnerability that allows unauthenticated attackers to execute arbitrary PHP code by invoking functions through the routing parameter. Attackers can craft requests to the index.php endpoint with malicious function parameters to execute system commands with application privileges.

Severity
critical
Software
PHP
Fixed in
5.0.23
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.0% — higher than 78% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 5.0.0

Until: 5.0.23

Fixed in: 5.0.23

How to fix this CVE

Upgrade PHP to version 5.0.24 or later to patch the remote code execution vulnerability in the routing parameter handler. This critical vulnerability allows unauthenticated attackers to execute arbitrary PHP code through specially crafted requests to index.php. Immediately apply the patch and restart your PHP application to mitigate exploitation risk.

sudo dnf update php

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST|GET /index\.php.*(?:function|invoke|call)\s*=|index\.php\?.*(?:system|exec|shell_exec|passthru|proc_open)

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement WAF rules to block requests to index.php containing function invocation parameters such as 'function=', 'invoke=', or 'call=' in the query string or POST body. Restrict routing parameter values to whitelisted function names only and reject requests with suspicious PHP function names (system, exec, shell_exec, eval, etc.).

How to check if you are affected

  1. Run `php -v` to verify the installed PHP version and confirm if it is 5.0.23 or earlier
  2. Check if PHP routing through index.php is enabled by reviewing your web server configuration (nginx/Apache) and PHP application bootstrap files
  3. Search web server logs for POST/GET requests containing suspicious function invocations via routing parameters, such as requests with `?function=system` or similar patterns
  4. After applying the patch, re-run `php -v` to confirm the version is 5.0.24 or later, and verify the application restarts without errors

FAQ

What is CVE-2018-25270?

CVE-2018-25270 is a critical remote code execution vulnerability in PHP versions 5.0.0 through 5.0.23 that allows attackers to invoke arbitrary functions through improperly validated routing parameters, leading to complete system compromise.

Is CVE-2018-25270 being actively exploited?

CVE-2018-25270 is not currently listed in the CISA Known Exploited Vulnerabilities catalog, and no public exploits have been released, though proof-of-concept code may exist in security research communities.

What versions of PHP are affected by CVE-2018-25270?

PHP versions 5.0.0 through 5.0.23 are affected; version 5.0.24 and later contain the fix.

How do I check if my server is vulnerable to CVE-2018-25270?

Run `php -v` to display your installed version. If the output shows a version between 5.0.0 and 5.0.23, your system is vulnerable and requires immediate patching.

Does Defensia detect CVE-2018-25270?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PHP is installed on a monitored server, CVE-2018-25270 will appear in your dashboard with remediation steps.

Related PHP CVEs

CVE-2026-28289CVSS 10FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. A patch bypass vulnerability for CVE-2026-27636 in FreeScout 1.8.206 and earlier allows any authenticated user with file upload permissions to achieve Remote Code Execution (RCE) on the server by uploading a malicious .htaccess file using a zero-width space character prefix to bypass the security check. The vulnerability exists in the sanitizeUploadedFileName() function in app/Http/Helper.php. The function contains a Time-of-Check to Time-of-Use (TOCTOU) flaw where the dot-prefix check occurs before sanitization removes invisible characters. This vulnerability is fixed in 1.8.207.
CVE-2025-47916CVSS 10Invision Community 5.0.0 before 5.0.7 allows remote code execution via crafted template strings to themeeditor.php. The issue lies within the themeeditor controller (file: /applications/core/modules/front/system/themeeditor.php), where a protected method named customCss can be invoked by unauthenticated users. This method passes the value of the content parameter to the Theme::makeProcessFunction() method; hence it is evaluated by the template engine. Accordingly, this can be exploited by unauthenticated attackers to inject and execute arbitrary PHP code by providing crafted template strings.
CVE-2025-62521CVSS 10ChurchCRM is an open-source church management system. Prior to version 5.21.0, a pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The vulnerability exists in `setup/routes/setup.php` where user input from the setup form is directly concatenated into a PHP configuration template without any validation or sanitization. Any parameter in the setup form can be used to inject PHP code that gets written to `Include/Config.php`, which is then executed on every page load. This is more severe than typical authenticated RCE vulnerabilities because it requires no credentials and affects the installation process that administrators must complete. Version 5.21.0 patches the issue.
CVE-2026-39337CVSS 10ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.
CVE-2025-25174CVSS 10Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in beeteam368 BeeTeam368 Extensions beeteam368-extensions allows PHP Local File Inclusion.This issue affects BeeTeam368 Extensions: from n/a through <= 1.9.4.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2018-25270. Free for 1 server.

Get started free