CVE-2016-3115·OpenSSH vulnerability
Multiple CRLF injection vulnerabilities in session.c in sshd in OpenSSH before 7.2p2 allow remote authenticated users to bypass intended shell-command restrictions via crafted X11 forwarding data, related to the (1) do_authenticated1 and (2) session_x11_req functions.
- Severity
- high
- Software
- OpenSSH
- Fixed in
- 1:7.2p2-1
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 36% — in the top 2% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
Until: 1:7.2p2-1
Fixed in: 1:7.2p2-1
How to fix this CVE
Update OpenSSH server to version 7.2p2-1 or later to patch CRLF injection vulnerabilities in X11 forwarding handling. These vulnerabilities allow authenticated users to bypass shell-command restrictions through malformed X11 forwarding data. Immediate patching is recommended for systems that permit X11 forwarding, especially in multi-user environments.
sudo dnf update openssh-server && sudo systemctl restart sshdDefensia detects this vulnerability
How to check if you are affected
- Run 'ssh -V' or 'sshd -v' to check the installed OpenSSH version; vulnerable versions are below 7.2p2
- Verify X11 forwarding is enabled by checking 'X11Forwarding' in /etc/ssh/sshd_config; if set to 'yes', the service is potentially exploitable
- Search SSH logs for anomalous X11 forwarding requests: grep -i 'x11' /var/log/auth.log | grep -i 'forwarding'
- Confirm the patch was applied by running 'ssh -V' again and verifying the version is 7.2p2-1 or later
FAQ
What is CVE-2016-3115?
CVE-2016-3115 is a CRLF injection flaw in OpenSSH's X11 forwarding implementation that allows authenticated attackers to inject carriage return/line feed characters into session handling, bypassing command restrictions that would normally be enforced by the SSH server.
Is CVE-2016-3115 being actively exploited?
CVE-2016-3115 is not listed as actively exploited by CISA; however, public proof-of-concept exploits are available, so the vulnerability remains a concern for systems that have not been patched.
What versions of OpenSSH are affected by CVE-2016-3115?
All versions of OpenSSH prior to 7.2p2 are vulnerable. This includes 7.1, 7.0, and all earlier versions that support X11 forwarding.
How do I check if my server is vulnerable to CVE-2016-3115?
Run 'ssh -V' to display the OpenSSH version; if it is below 7.2p2 and X11Forwarding is enabled in /etc/ssh/sshd_config, your server is vulnerable.
Does Defensia detect CVE-2016-3115?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If OpenSSH is installed on a monitored server, CVE-2016-3115 will appear in your dashboard with remediation steps.
Related OpenSSH CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2016-3115. Free for 1 server.
Get started free