CVE-2026-99237·Kernel vulnerability
In the Linux kernel, the following vulnerability has been resolved: tracing: Hold trace_types_lock when resetting last boot data from readers update_last_data_if_empty() is called from tracing_open() with O_TRUNC, tracing_read_pipe() and tracing_buffers_read() without trace_types_lock. Two readers can both pass the LAST_BOOT test and free module_delta twice, and a module notifier can update module_delta while it is being freed. Take trace_types_lock in those paths and keep the callers that already hold it on an unlocked variant.
- Severity
- high
- Software
- Kernel
- Fixed in
- 6.18.60, 7.2.14, 7.3.1
- Published
How to fix this CVE
Update your Linux kernel to one of the fixed stable releases: 6.18.60, 7.2.14, or 7.3.1, depending on which kernel series your system currently runs. This resolves a race condition in the kernel's tracing subsystem where concurrent readers could trigger double-free vulnerabilities and memory corruption. Most users should install their distribution's patched kernel package rather than compiling from source.
sudo dnf update kernel kernel-develDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check your current kernel version with `uname -r` and compare against the fixed versions (6.18.60, 7.2.14, 7.3.1)
- Step 2: Verify if the trace_types_lock synchronization is present by checking if your kernel includes the commit 1f06cfe0b60a878619d1d8efe1cd0f515b7dc2aa using `git log --oneline | grep 1f06cfe0b60a`
- Step 3: Search kernel logs for tracing-related memory errors with `dmesg | grep -i 'double free\|use-after-free\|memory corruption\|tracing'` to detect past exploitation attempts
- Step 4: After patching, verify the new kernel version with `uname -r` and confirm it matches one of the fixed releases, then reboot to apply changes
FAQ
What is CVE-2026-99237?
This vulnerability is a race condition in the Linux kernel's tracing infrastructure where multiple concurrent readers of trace buffers can bypass synchronization checks, leading to double-free memory corruption and privilege escalation on affected systems.
Is CVE-2026-99237 being actively exploited?
No, there are currently no reports of active exploitation or public exploit code available for this vulnerability. However, its high CVSS score (7.8) warrants prompt patching.
What versions of Kernel are affected by CVE-2026-99237?
The vulnerability affects kernel versions prior to 6.18.60, 7.2.14, and 7.3.1. The exact affected range is not fully disclosed, but all LTS and stable kernels released before these fixed versions should be considered vulnerable.
How do I check if my server is vulnerable to CVE-2026-99237?
Run `uname -r` to check your kernel version. If it is older than 6.18.60, 7.2.14, or 7.3.1 (depending on your branch), your system is vulnerable. Cross-reference your version with the NVD CVE record for your specific branch.
Does Defensia detect CVE-2026-99237?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Kernel is installed on a monitored server, CVE-2026-99237 will appear in your dashboard with remediation steps.
Related Kernel CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-99237. Free for 1 server.
Get started free