CVE-2026-94054·Exim vulnerability
Exim before 4.100.1, when Proxy-Protocol is used with an attacker-controlled proxy, has an out-of-bounds write.
- Severity
- high
- Software
- Exim
- Fixed in
- 4.100.1
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.27% — higher than 19% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-94054 scores 7 on CVSS, so a successful attack would be serious — but at 0.27%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
Until: 4.100.1
Fixed in: 4.100.1
How to fix this CVE
Upgrade Exim to version 4.100.1 or later to address a memory corruption vulnerability that can occur when the Proxy-Protocol extension is enabled and processing connections from an untrusted proxy source. Organizations using Exim with Proxy-Protocol should prioritize this update to prevent potential denial of service or information disclosure attacks.
sudo dnf update eximDefensia detects this vulnerability
What an exploitation attempt looks like
Sample log line indicative of exploitation attempts:
Proxy-Protocol connection attempts with malformed or oversized headers followed by exim process crashes or segmentation faults in syslog; pattern: `exim\[\d+\]: segfault|exim\[\d+\]: out of bounds|PROXY TCP[46].*overflow`How to check if you are affected
- Step 1: Check the installed Exim version by running `exim -bV | head -n 1` and verify it is 4.100.1 or later
- Step 2: Verify if Proxy-Protocol is enabled in your Exim configuration by checking for 'proxy_protocol_timeout' or 'proxy_protocol_networks' settings in /etc/exim4/exim4.conf.localsettings
- Step 3: Search Exim logs for abnormal connection patterns from proxy sources using `grep -i 'proxy' /var/log/exim4/main.log | grep -i 'error\|fail\|corruption'`
- Step 4: After applying the patch, re-run `exim -bV | head -n 1` to confirm the version is now 4.100.1 or higher
FAQ
What is CVE-2026-94054?
This vulnerability is an out-of-bounds write condition in Exim's Proxy-Protocol handler that can be triggered by sending specially crafted connection data through an attacker-controlled proxy, potentially leading to memory corruption and system instability.
Is CVE-2026-94054 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits have been disclosed, though organizations should still patch promptly as the vulnerability is network-accessible.
What versions of Exim are affected by CVE-2026-94054?
All versions of Exim prior to 4.100.1 are vulnerable when Proxy-Protocol is enabled. Organizations running Exim 4.100.0 and earlier should upgrade immediately.
How do I check if my server is vulnerable to CVE-2026-94054?
Run `exim -bV` to check your version; if it shows a version before 4.100.1, your system is vulnerable. Additionally, confirm that Proxy-Protocol is configured by checking for related settings in your Exim configuration files.
Does Defensia detect CVE-2026-94054?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Exim is installed on a monitored server, CVE-2026-94054 will appear in your dashboard with remediation steps.
Related Exim CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-94054. Free for 1 server.
Get started free