high CVSS 7.4 EPSS 0.14%

CVE-2026-66141·Exim vulnerability

Exim before 4.99.5 allows .forward privilege escalation because force_command for a pipe transport is mishandled.

Severity
high
Software
Exim
Fixed in
4.99.5
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.14% — higher than 3% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-66141 scores 7.4 on CVSS, so a successful attack would be serious — but at 0.14%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 4.99.5

Fixed in: 4.99.5

How to fix this CVE

Update Exim to version 4.99.5 or later to address a privilege escalation vulnerability in the pipe transport handler. The issue stems from improper handling of the force_command directive, which could allow local attackers to escalate privileges. Prioritize this update on systems where Exim handles mail processing with untrusted user accounts or shell access.

sudo dnf update exim

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check installed Exim version with: exim -bV | head -1
  2. Step 2: Verify if pipe transport is configured by checking: grep -i 'transport.*pipe' /etc/exim4/exim4.conf.d/* 2>/dev/null || grep -i 'driver = pipe' /etc/exim4/exim4.conf 2>/dev/null
  3. Step 3: Search for force_command usage in transport configs with: grep -rn 'force_command' /etc/exim4/ 2>/dev/null
  4. Step 4: After patching, confirm the new version with: exim -bV | head -1 and verify it reports 4.99.5 or later

FAQ

What is CVE-2026-66141?

This vulnerability affects Exim's pipe transport mechanism, where improper validation of the force_command parameter allows local attackers with mail processing privileges to bypass security restrictions and escalate to higher privilege levels. This affects mail servers that delegate command execution through Exim transports.

Is CVE-2026-66141 being actively exploited?

No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available. However, the high CVSS score warrants prompt patching before weaponization.

What versions of Exim are affected by CVE-2026-66141?

All versions of Exim prior to 4.99.5 are vulnerable. Systems running Exim 4.99.4 and earlier should be updated immediately.

How do I check if my server is vulnerable to CVE-2026-66141?

Run 'exim -bV | grep -oP 'Exim version \K[0-9.]+'' to extract your version number, then compare it against 4.99.5. If your version is lower, you are vulnerable.

Does Defensia detect CVE-2026-66141?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Exim is installed on a monitored server, CVE-2026-66141 will appear in your dashboard with remediation steps.

Related Exim CVEs

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-66141. Free for 1 server.

Get started free