CVE-2026-66140·Exim vulnerability
Exim before 4.99.5 allows directory traversal to access files outside of the spool area, and consequently gain privileges, because arguments related to queue-name are mishandled.
- Severity
- high
- Software
- Exim
- Fixed in
- 4.99.5
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.39% — higher than 31% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-66140 scores 8.4 on CVSS, so a successful attack would be serious — but at 0.39%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
Until: 4.99.5
Fixed in: 4.99.5
How to fix this CVE
Exim versions prior to 4.99.5 contain a local privilege escalation flaw in queue-name argument handling that permits attackers to traverse outside the mail spool directory and access sensitive files. Immediately upgrade Exim to version 4.99.5 or later to patch this vulnerability. Review file permissions on your Exim spool directory and ensure proper access controls are in place to minimize local attack surface.
sudo dnf update eximDefensia detects this vulnerability
How to check if you are affected
- Check installed Exim version: exim -v | grep version
- Verify spool directory permissions: ls -ld /var/spool/exim4 (should be 700 or 750 owned by Debian-exim)
- Search for queue-name traversal attempts in mail logs: grep -E '(\.\.|\.\./|queue.*name)' /var/log/exim4/mainlog
- Confirm patch applied by running: exim -v and verifying version is 4.99.5 or greater
FAQ
What is CVE-2026-66140?
This vulnerability is a local privilege escalation in Exim's queue-name argument processing that allows an attacker with local system access to bypass spool directory restrictions and read or modify files outside the intended mail queue area.
Is CVE-2026-66140 being actively exploited?
No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, but it should still be patched promptly due to its high severity rating.
What versions of Exim are affected by CVE-2026-66140?
All Exim versions before 4.99.5 are affected. The exact earliest vulnerable version is unknown, but organizations running any version below 4.99.5 should upgrade immediately.
How do I check if my server is vulnerable to CVE-2026-66140?
Run `exim -v` and compare the version number to 4.99.5. If your version is lower, your system is vulnerable. You can also use: `dpkg -l | grep exim` on Debian/Ubuntu or `rpm -q exim` on RHEL/CentOS.
Does Defensia detect CVE-2026-66140?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Exim is installed on a monitored server, CVE-2026-66140 will appear in your dashboard with remediation steps.
Related Exim CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-66140. Free for 1 server.
Get started free