medium CVSS 4.3 EPSS 0.30%

CVE-2026-6575·PostgreSQL vulnerability

Buffer over-read in PostgreSQL function pg_restore_attribute_stats() accepts array values of unmatched length, which causes query planning to read past end of one array. This allows a table maintainer to infer memory values past that array end. Within major version 18, minor versions before PostgreSQL 18.4 are affected. Versions before PostgreSQL 18 are unaffected.

Severity
medium
Software
PostgreSQL
Fixed in
18.4
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.30% — higher than 21% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 18.0

Until: 18.4

Fixed in: 18.4

How to fix this CVE

PostgreSQL 18.0 through 18.3 contain a buffer over-read vulnerability in the pg_restore_attribute_stats() function that permits authenticated table maintainers to read unintended memory values. Upgrade to PostgreSQL 18.4 or later to remediate this information disclosure vulnerability and prevent unauthorized memory access.

sudo dnf update postgresql-server postgresql-contrib postgresql-libs

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed PostgreSQL version: psql --version or SELECT version(); in a psql session
  2. Verify the vulnerable component is active: SELECT * FROM pg_extension WHERE extname='pg_restore'; to check if extension is loaded
  3. Search PostgreSQL logs for pg_restore_attribute_stats() calls: grep -i 'pg_restore_attribute_stats' /var/log/postgresql/*.log
  4. Confirm remediation by verifying upgraded version matches 18.4 or later: SELECT version();

FAQ

What is CVE-2026-6575?

CVE-2026-6575 is a buffer over-read flaw in PostgreSQL 18.x that allows authenticated table maintainers to infer sensitive memory contents by passing mismatched array lengths to query planning functions, leading to information disclosure.

Is CVE-2026-6575 being actively exploited?

No, this vulnerability is not listed in CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available. However, the medium severity rating warrants timely patching.

What versions of PostgreSQL are affected by CVE-2026-6575?

PostgreSQL versions 18.0 through 18.3 are affected. PostgreSQL 17 and earlier versions are unaffected. The fix is available in PostgreSQL 18.4 and later.

How do I check if my server is vulnerable to CVE-2026-6575?

Run 'psql --version' or connect to your database and execute 'SELECT version();' to display the PostgreSQL version. If it returns 18.0, 18.1, 18.2, or 18.3, your server is vulnerable.

Does Defensia detect CVE-2026-6575?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PostgreSQL is installed on a monitored server, CVE-2026-6575 will appear in your dashboard with remediation steps.

Related PostgreSQL CVEs

CVE-2026-14669CVSS 8.8Heap buffer overflow in PostgreSQL to_char(timestamptz) allows the party choosing the timezone to execute arbitrary code as the operating system user running the database, via a long POSIX timezone abbreviation. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-14671CVSS 8.8Type confusion in PostgreSQL module "refint" allows an object creator to execute arbitrary code as the operating system user running the database. The fix for this emerged as a non-security bug report, and the fix appear in the git repository with subject "refint: Remove plan cache.", without a CVE number. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-14670CVSS 8.8Heap buffer overflow in PostgreSQL plperl return of a tied hash allows the function owner to execute arbitrary code as the operating system user running the database, via a crafted function body. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-15742CVSS 8.8Integer wraparound in PostgreSQL fuzzystrmatch allows a user to direct writes to a huge range of addresses, executing arbitrary code as the operating system user running the database, via extreme inputs to SQL function levenshtein() or levenshtein_less_equal(). Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-16238CVSS 8.8Type confusion in PostgreSQL pg_restore_attribute_stats() allows an object creator to execute arbitrary code as the operating system user running the database, via conflation of range and multirange values. Within major version 18, minor versions before PostgreSQL 18.6 are affected. Versions before PostgreSQL 18 are unaffected.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-6575. Free for 1 server.

Get started free