CVE-2026-6479·PostgreSQL vulnerability
Uncontrolled recursion in PostgreSQL SSL and GSS negotiation allows an attacker able to connect to a PostgreSQL AF_UNIX socket to achieve sustained denial of service. If SSL and GSS are both disabled, an attacker can do the same via access to a PostgreSQL TCP socket. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.
- Severity
- high
- Software
- PostgreSQL
- Fixed in
- 18.4
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.60% — higher than 47% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-6479 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.60%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
From: 18.0
Until: 18.4
Fixed in: 18.4
How to fix this CVE
Upgrade PostgreSQL to version 18.4 or later to patch a recursion flaw in the SSL/GSS negotiation handler that enables denial-of-service attacks. Organizations running PostgreSQL 18.0–18.3 should prioritize this update immediately, especially if Unix socket or unauthenticated TCP access is permitted. Apply the patch during a maintenance window to prevent service interruption.
sudo dnf update postgresql-server-18-18.4Defensia detects this vulnerability
How to check if you are affected
- Run `psql --version` or query `SELECT version();` in PostgreSQL to confirm the installed version number.
- Check if PostgreSQL is configured to accept connections via AF_UNIX sockets by inspecting `/var/run/postgresql/` and verifying the presence of socket files.
- Review PostgreSQL logs in `/var/log/postgresql/` for repeated connection errors, protocol negotiation failures, or messages indicating abnormal SSL/GSS negotiation attempts.
- After patching, verify the fix by running `psql --version` again and confirm the version is 18.4 or higher, then restart PostgreSQL with `sudo systemctl restart postgresql`.
FAQ
What is CVE-2026-6479?
CVE-2026-6479 is a denial-of-service vulnerability in PostgreSQL's SSL and GSS authentication negotiation code that permits unbounded recursion, allowing attackers to exhaust server resources and crash the database service.
Is CVE-2026-6479 being actively exploited?
No, this vulnerability is not listed on CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploits have been disclosed.
What versions of PostgreSQL are affected by CVE-2026-6479?
PostgreSQL versions 18.0 through 18.3 are vulnerable. The vulnerability is also present in earlier branches (17.x, 16.x, 15.x, 14.x) but only version 18 through 18.4 is specified in this CVE scope.
How do I check if my server is vulnerable to CVE-2026-6479?
Run `psql -U postgres -c 'SELECT version();'` to retrieve the PostgreSQL version. If the output shows a version between 18.0 and 18.3, your installation is vulnerable.
Does Defensia detect CVE-2026-6479?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PostgreSQL is installed on a monitored server, CVE-2026-6479 will appear in your dashboard with remediation steps.
Related PostgreSQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-6479. Free for 1 server.
Get started free