medium CVSS 4.3 EPSS 0.31%

CVE-2026-6474·PostgreSQL vulnerability

Externally-controlled format string in PostgreSQL timeofday() function allows an attacker to retrieve portions of server memory, via crafted timezone zones. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

Severity
medium
Software
PostgreSQL
Fixed in
18.4
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.31% — higher than 22% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

From: 18.0

Until: 18.4

Fixed in: 18.4

How to fix this CVE

Upgrade PostgreSQL to version 18.4 or later to patch a format string vulnerability in the timeofday() function that could leak sensitive server memory. This vulnerability requires authenticated database access to exploit, so immediate patching is recommended for systems with untrusted database users.

sudo dnf update postgresql-server postgresql-contrib postgresql-libs

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check your PostgreSQL version by running `psql --version` or connecting to the database and executing `SELECT version();`
  2. Step 2: Identify users with database connection privileges by querying `SELECT usename, usecanlogin FROM pg_user;` to understand your attack surface
  3. Step 3: Search PostgreSQL logs (typically in /var/log/postgresql/) for calls to the timeofday() function combined with unusual timezone parameters using `grep -i 'timeofday' /var/log/postgresql/*.log`
  4. Step 4: After upgrading, verify the new version with `psql --version` and confirm the fix by checking that FORMAT strings in timezone handling no longer trigger memory disclosure

FAQ

What is CVE-2026-6474?

This is a format string vulnerability in PostgreSQL's timeofday() function that allows authenticated users to read portions of server memory by supplying malicious timezone parameters. The flaw stems from improper handling of user-controlled data in format string operations.

Is CVE-2026-6474 being actively exploited?

No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available. However, the low barrier to exploitation (requiring only database authentication) means patching should not be delayed.

What versions of PostgreSQL are affected by CVE-2026-6474?

PostgreSQL versions 18.0 through 18.3 are vulnerable. Earlier major version branches (17.x before 17.10, 16.x before 16.14, 15.x before 15.18, and 14.x before 14.23) also contain this flaw in their respective release lines.

How do I check if my server is vulnerable to CVE-2026-6474?

Connect to your PostgreSQL instance and run `SELECT version();` to check the version number. If it matches 18.0–18.3 or the affected releases in earlier branches, your system is vulnerable and requires immediate patching.

Does Defensia detect CVE-2026-6474?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PostgreSQL is installed on a monitored server, CVE-2026-6474 will appear in your dashboard with remediation steps.

Related PostgreSQL CVEs

CVE-2026-14669CVSS 8.8Heap buffer overflow in PostgreSQL to_char(timestamptz) allows the party choosing the timezone to execute arbitrary code as the operating system user running the database, via a long POSIX timezone abbreviation. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-14671CVSS 8.8Type confusion in PostgreSQL module "refint" allows an object creator to execute arbitrary code as the operating system user running the database. The fix for this emerged as a non-security bug report, and the fix appear in the git repository with subject "refint: Remove plan cache.", without a CVE number. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-14670CVSS 8.8Heap buffer overflow in PostgreSQL plperl return of a tied hash allows the function owner to execute arbitrary code as the operating system user running the database, via a crafted function body. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-15742CVSS 8.8Integer wraparound in PostgreSQL fuzzystrmatch allows a user to direct writes to a huge range of addresses, executing arbitrary code as the operating system user running the database, via extreme inputs to SQL function levenshtein() or levenshtein_less_equal(). Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
CVE-2026-16238CVSS 8.8Type confusion in PostgreSQL pg_restore_attribute_stats() allows an object creator to execute arbitrary code as the operating system user running the database, via conflation of range and multirange values. Within major version 18, minor versions before PostgreSQL 18.6 are affected. Versions before PostgreSQL 18 are unaffected.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-6474. Free for 1 server.

Get started free