critical CVSS 9.9 EPSS 0.31%

CVE-2026-55454·Docker vulnerability

Appsmith is a platform to build admin panels, internal tools, and dashboards. Prior to 2.1, the bundled Caddy reverse-proxy's admin API — which has no authentication by default — is bound on 0.0.0.0:2019 inside the container. While this listener is not directly published to the host by docker-compose.yml, it is reachable from the Appsmith server process itself or a SSRF vulnerability. An authenticated low-privileged user can therefore drive the SSRF to issue POST /load (or any other admin-API call) against http://0.0.0.0:2019/, fully replacing the live Caddy configuration and taking over the reverse proxy. This vulnerability is fixed in 2.1.

Severity
critical
Software
Docker
Fixed in
2.1
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.31% — higher than 23% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-55454 scores 9.9 on CVSS, so a successful attack would be serious — but at 0.31%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 2.1

Fixed in: 2.1

How to fix this CVE

Upgrade Docker to version 2.1 or later to patch the unauthenticated Caddy reverse-proxy admin API exposure. This vulnerability allows authenticated users to leverage Server-Side Request Forgery (SSRF) to reconfigure the reverse proxy and intercept traffic. Immediately update your Docker installation and restart affected containers to apply the security fix.

sudo dnf upgrade -y docker-ce

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check Docker version: docker --version | grep -oP '\d+\.\d+' and confirm it is 2.1 or later
  2. Step 2: Verify Caddy admin API is not exposed: netstat -tlnp | grep 2019 or ss -tlnp | grep 2019 (should return no results if not running)
  3. Step 3: Check container logs for suspicious POST requests to /load endpoint: docker logs <container-name> | grep -i 'caddy\|/load\|2019'
  4. Step 4: Confirm the patch: docker inspect <image-id> | grep -i version and verify the image version is 2.1+

FAQ

What is CVE-2026-55454?

This vulnerability exposes Docker's bundled Caddy reverse-proxy admin API without authentication on port 2019. An authenticated attacker can abuse SSRF to remotely reconfigure the reverse proxy, allowing full interception and manipulation of application traffic.

Is CVE-2026-55454 being actively exploited?

No, this vulnerability is not currently listed in CISA's Known Exploited Vulnerabilities (KEV) catalog, and no public exploit code has been released. However, the attack method is straightforward for authenticated users with network access.

What versions of Docker are affected by CVE-2026-55454?

All versions of Docker prior to version 2.1 are affected. Version 2.1 and later include the security patch.

How do I check if my server is vulnerable to CVE-2026-55454?

Run 'docker --version' to check your installed version. If it is below 2.1, your installation is vulnerable. Additionally, test internal connectivity: 'curl -v http://127.0.0.1:2019/' from within a container; if port 2019 responds, the admin API is exposed.

Does Defensia detect CVE-2026-55454?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Docker is installed on a monitored server, CVE-2026-55454 will appear in your dashboard with remediation steps.

Related Docker CVEs

CVE-2026-40281CVSS 10Gotenberg is a Docker-powered stateless API for PDF files. In versions 8.30.1 and earlier, the metadata write endpoint validates metadata keys for control characters but leaves metadata values unsanitized. A newline character in a metadata value splits the ExifTool stdin line into two separate arguments, allowing injection of arbitrary ExifTool pseudo-tags such as -FileName, -Directory, -SymLink, and -HardLink. This is a bypass of the incomplete key-sanitization fix introduced in v8.30.1. An unauthenticated attacker can rename or move any PDF being processed to an arbitrary path in the container filesystem, overwrite arbitrary files, or create symlinks and hard links at arbitrary paths.
CVE-2026-33587CVSS 10Lack of user input sanitisation in Open Notebook v1.8.3 allows the application user to execute Python code (and subsequently OS commands) on the docker container via Server-Side Template Injection (SSTI) for user-created transformations.
CVE-2026-57572CVSS 10Crawl4AI is an open-source LLM-friendly web crawler and scraper. Prior to 0.9.0, the Docker API server accepted request-supplied browser_config.extra_args, which flowed into Chromium's launch arguments. An attacker could inject Chromium switches that replace a child-process launch command together with --no-zygote, causing Chromium to fork or exec an attacker-controlled command as the container's runtime user. The Docker API is unauthenticated by default, so a single request yields arbitrary command execution. This issue is fixed in version 0.9.0.
CVE-2026-42298CVSS 10Postiz is an AI social media scheduling tool. Prior to commit da44801, a "Pwn Request" vulnerability in the Build and Publish PR Docker Image workflow (.github/workflows/pr-docker-build.yml) allows any unauthenticated user to execute arbitrary code during the Docker build process and exfiltrate a highly privileged GITHUB_TOKEN (write-all permissions). This can be achieved simply by opening a Pull Request from a fork with a maliciously modified Dockerfile.dev. This issue has been patched via commit da44801.
CVE-2026-26216CVSS 10Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing unauthenticated remote attackers to import arbitrary modules and execute system commands. Successful exploitation allows full server compromise, including arbitrary command execution, file read and write access, sensitive data exfiltration, and lateral movement within internal networks.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-55454. Free for 1 server.

Get started free