CVE-2026-52681·Dovecot vulnerability
Sieve CPU resource usage is tracked in the compiled script, so an attacker that has valid credentials can reset the accounting by repeatedly changing the active script. Compiled script files are also not removed when a script is deleted or renamed. The configured Sieve CPU limit can be bypassed, allowing sustained CPU consumption, and the leftover files increase disk consumption. Both can cause degradation of service for mail delivery. Monitor system for abnormal CPU usage and disk consumption. Update to non-vulnerable version. No publicly available exploits are known.
- Severity
- high
- Software
- Dovecot
- Fixed in
- 1:2.4.1+dfsg1-6+deb13u7
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.30% — higher than 20% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-52681 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.30%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
Until: 1:2.4.1+dfsg1-6+deb13u7
Fixed in: 1:2.4.1+dfsg1-6+deb13u7
How to fix this CVE
Upgrade Dovecot to version 1:2.4.1+dfsg1-6+deb13u7 or later to address a resource accounting bypass in the Sieve mail filtering subsystem. This vulnerability allows authenticated attackers to circumvent CPU limits and accumulate orphaned compiled script files, potentially degrading mail delivery performance. Apply the patch immediately and monitor your system for unusual CPU and disk usage patterns during the transition.
sudo dnf update dovecotDefensia detects this vulnerability
How to check if you are affected
- Run `dovecot --version` to display the currently installed Dovecot version and compare it against 1:2.4.1+dfsg1-6+deb13u7
- Verify Sieve support is enabled by checking if the sieve and sieve_global plugins are loaded in `/etc/dovecot/conf.d/90-sieve.conf`
- Search your Sieve script directory (typically `/var/lib/dovecot/sieve/`) for orphaned `.svbin` compiled script files that lack corresponding `.sieve` source files using `find /var/lib/dovecot/sieve/ -name '*.svbin' -type f`
- After patching, confirm the new version with `dovecot --version` and restart the Dovecot service using `sudo systemctl restart dovecot`
FAQ
What is CVE-2026-52681?
This vulnerability exists in Dovecot's Sieve mail filtering engine, where the CPU resource accounting mechanism can be reset by repeatedly modifying the active Sieve script. Additionally, compiled script binaries are not cleaned up when scripts are deleted, allowing an authenticated user to exhaust CPU and disk resources.
Is CVE-2026-52681 being actively exploited?
No. This CVE is not listed on CISA's Known Exploited Vulnerabilities catalog, and no public exploits are currently available. However, any user with valid mail account credentials can exploit this vulnerability.
What versions of Dovecot are affected by CVE-2026-52681?
All Dovecot versions up to and including 1:2.4.1+dfsg1-6+deb13u6 are affected. The fix was introduced in version 1:2.4.1+dfsg1-6+deb13u7.
How do I check if my server is vulnerable to CVE-2026-52681?
Run `dpkg -l | grep dovecot` on Debian/Ubuntu systems or `rpm -qa dovecot` on RHEL/CentOS, then compare the version against 1:2.4.1+dfsg1-6+deb13u7. If your version is older, you are vulnerable.
Does Defensia detect CVE-2026-52681?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Dovecot is installed on a monitored server, CVE-2026-52681 will appear in your dashboard with remediation steps.
Related Dovecot CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-52681. Free for 1 server.
Get started free