critical CVSS 9.8 EPSS <0.1%

CVE-2026-48207·Python vulnerability

Deserialization of untrusted data in Apache Fory PyFory. PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes. This issue affects Apache Fory: from before 1.0.0. Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.

Severity
critical
Software
Python
Fixed in
1.0.0
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at <0.1% — higher than 13% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-48207 scores 9.8 on CVSS, so a successful attack would be serious — but at <0.1%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 0.13.0

Until: 1.0.0

Fixed in: 1.0.0

How to fix this CVE

Apache Fory PyFory versions before 1.0.0 contain a critical deserialization bypass that allows attackers to circumvent security policies when processing untrusted data in Python-native mode. Immediately upgrade to Apache Fory 1.0.0 or later, which enforces proper DeserializationPolicy validation across all serializer code paths. Review your application's deserialization configuration to ensure strict mode is enabled and untrusted data sources are properly validated.

sudo dnf update python3-pyfory

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check installed Apache Fory version with `python3 -c "import pyfory; print(pyfory.__version__)"` and compare against version 1.0.0 or later
  2. Step 2: Search your application code for ReduceSerializer usage patterns: `grep -r "ReduceSerializer" /path/to/app --include="*.py"`
  3. Step 3: Check if DeserializationPolicy is defined and strict mode is enabled by searching for `DeserializationPolicy` and `strict_mode=False` configurations
  4. Step 4: After patching, re-run `python3 -c "import pyfory; print(pyfory.__version__)"` to confirm version 1.0.0+ is installed and restart all Python services

FAQ

What is CVE-2026-48207?

This vulnerability is a deserialization policy bypass in Apache Fory's ReduceSerializer component that allows attackers to instantiate unsafe classes or functions by exploiting gaps in the validation logic when processing reduce-state restoration and global-name resolution during object deserialization.

Is CVE-2026-48207 being actively exploited?

No, this vulnerability is not listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available, though this does not eliminate the risk if your application deserializes untrusted data.

What versions of Apache Fory PyFory are affected by CVE-2026-48207?

Versions 0.13.0 through 1.0.0 are affected; users must upgrade to version 1.0.0 or later to receive the fix.

How do I check if my server is vulnerable to CVE-2026-48207?

Run `python3 -c "import pyfory; print(pyfory.__version__)"` to determine the installed version; if it is below 1.0.0 and your application uses ReduceSerializer with untrusted data inputs, your system is vulnerable.

Does Defensia detect CVE-2026-48207?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Apache Fory PyFory is installed on a monitored server, CVE-2026-48207 will appear in your dashboard with remediation steps.

Related Python CVEs

CVE-2026-28505CVSS 10Tautulli is a Python based monitoring and tracking tool for Plex Media Server. Prior to version 2.17.0, the str_eval() function in notification_handler.py implements a sandboxed eval() for notification text templates. The sandbox attempts to restrict callable names by inspecting code.co_names of the compiled code object. However, co_names only contains names from the outer code object. When a lambda expression is used, it creates a nested code object whose attribute accesses are stored in code.co_consts, NOT in code.co_names. The sandbox never inspects nested code objects. This issue has been patched in version 2.17.0.
CVE-2026-33054CVSS 10Mesop is a Python-based UI framework that allows users to build web applications. Versions 1.2.2 and below contain a Path Traversal vulnerability that allows any user supplying an untrusted state_token through the UI stream payload to arbitrarily target files on the disk under the standard file-based runtime backend. This can result in application denial of service (via crash loops when reading non-msgpack target files as configurations), or arbitrary file manipulation. This vulnerability heavily exposes systems hosted utilizing FileStateSessionBackend. Unauthorized malicious actors could interact with arbitrary payloads overwriting or explicitly removing underlying service resources natively outside the application bounds. This issue has been fixed in version 1.2.3.
CVE-2026-25632CVSS 10EPyT-Flow is a Python package designed for the easy generation of hydraulic and water quality scenario data of water distribution networks. Prior to 0.16.1, EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files. This vulnerability is fixed in 0.16.1.
CVE-2026-34938CVSS 10PraisonAI is a multi-agent teams system. Prior to version 1.5.90, execute_code() in praisonai-agents runs attacker-controlled Python inside a three-layer sandbox that can be fully bypassed by passing a str subclass with an overridden startswith() method to the _safe_getattr wrapper, achieving arbitrary OS command execution on the host. This issue has been patched in version 1.5.90.
CVE-2026-8481CVSS 9.9IBM Langflow OSS 1.0.0 through 1.10.0 contain a critical remote code execution vulnerability in the code validation API endpoint. The POST /api/v1/validate/code endpoint accepts user-supplied Python code and executes it directly using Python's built-in exec() function without sandboxing, input validation, or privilege restrictions, enabling any authenticated user to execute arbitrary system commands with the full privileges of the Langflow server process.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-48207. Free for 1 server.

Get started free