medium CVSS 4.3 EPSS 0.82%

CVE-2026-42006·Dovecot vulnerability

An attacker can cause uncontrolled memory usage with excessive bracing over IMAP. The fix in CVE-2026-27857 was incomplete, only blocking one way of doing this, so there was still another way left open. In particular, the fix was for closing braces, but you could still use open braces to bypass the limit. Using excessive bracing, attacker can cause memory usage up to configured memory limit. Install fixed version, or configure vsz_limit for imap process to low value. No publicly available exploits are known.

Severity
medium
Software
Dovecot
Fixed in
2.4.4
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.82% — higher than 56% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.4

Fixed in: 2.4.4

How to fix this CVE

Upgrade Dovecot to version 2.4.4 or later to patch the incomplete fix for IMAP memory exhaustion. If immediate patching is not possible, configure a restrictive vsz_limit parameter for IMAP processes to prevent runaway memory consumption. This vulnerability allows authenticated attackers to bypass previous mitigation attempts by exploiting open braces in IMAP commands.

sudo dnf update dovecot

Defensia detects this vulnerability

How to check if you are affected

  1. Check the installed Dovecot version: dovecot --version
  2. Verify IMAP service is enabled: systemctl status dovecot | grep -i imap
  3. Search authentication logs for repeated IMAP connection attempts with unusual brace patterns: grep -i 'imap' /var/log/auth.log | grep -c '{' to count open brace usage
  4. Confirm the patch: dovecot --version should show 2.4.4 or higher; cross-reference with dpkg -l | grep dovecot (Debian/Ubuntu) or rpm -q dovecot (RHEL/CentOS)

FAQ

What is CVE-2026-42006?

CVE-2026-42006 is a memory exhaustion vulnerability in Dovecot's IMAP server that allows authenticated users to trigger excessive memory consumption by sending malformed IMAP commands with unbalanced braces. The original CVE-2026-27857 patch only addressed closing braces, leaving open braces as an attack vector.

Is CVE-2026-42006 being actively exploited?

No, CVE-2026-42006 is not listed in the CISA KEV catalog and no public exploits are currently available, though the vulnerability does require valid IMAP credentials to exploit.

What versions of Dovecot are affected by CVE-2026-42006?

All versions of Dovecot prior to 2.4.4 are affected by this vulnerability.

How do I check if my server is vulnerable to CVE-2026-42006?

Run 'dovecot --version' and compare the output to 2.4.4. If your version is lower, your server is vulnerable. Additionally, check if IMAP is enabled in your Dovecot configuration file (/etc/dovecot/dovecot.conf) and the vsz_limit setting for the imap process.

Does Defensia detect CVE-2026-42006?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Dovecot is installed on a monitored server, CVE-2026-42006 will appear in your dashboard with remediation steps.

Related Dovecot CVEs

CVE-2026-73208CVSS 9An attacker that holds a token intended for a different purpose can authenticate, because when an OAuth2 token response does not contain a scope claim, the audience claim is used in its place and checked against the configured required scopes. These are different concepts, and the audience claim does not describe what a token is allowed to do. A token that grants no relevant permissions can be accepted because its intended recipient value happens to match a configured scope name, granting access that should have been denied. It also hides an identity provider misconfiguration where scopes are not being issued at all. Ensure the identity provider issues a scope claim for all tokens used with Dovecot, and that configured scope names do not match audience values. Update to non-vulnerable version. No publicly available exploits are known.
CVE-2026-40018CVSS 9None None None No publicly available exploits are known.
CVE-2026-40019CVSS 9An unauthenticated attacker can send a truncated quoted argument to the ManageSieve login process, which makes it spin in an infinite loop consuming CPU. This can cause degradation or denial of service for Sieve script management, and repeated connections can consume all available CPU on the server. Monitor system for abnormal CPU usage and kill the offending process. Restrict network access to the ManageSieve service to trusted clients. Update to non-vulnerable version. No publicly available exploits are known.
CVE-2026-33605CVSS 9An unauthenticated attacker can crash the ManageSieve login process by sending a small malformed command before authenticating. If running in high-security mode (default for community releases), only the attacker's own connection is terminated. If running in high-performance mode (default for Pro releases), all connections handled by the same managesieve-login process are terminated. Repeating the attack can cause denial of service for Sieve script management. Restrict network access to the ManageSieve service to trusted clients. Update to non-vulnerable version. No publicly available exploits are known.
CVE-2026-27852CVSS 9An attacker that can send mail to a user can craft a message whose headers contain a very large number of email addresses or MIME parameters, which causes excessive memory usage when the message is later parsed. The message is still delivered, but reading it over IMAP can exhaust the memory limit of the process and terminate it, causing denial of service for the affected user. Update to non-vulnerable version. No publicly available exploits are known.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-42006. Free for 1 server.

Get started free