medium CVSS 5.3 EPSS 0.43%

CVE-2026-40016·Dovecot vulnerability

Attacker can upload a malicious Sieve script over ManageSieve service (or locally) to bypass configured CPU time limits for Sieve up to 130 times of the configured limit. Attacker can use this to degrade server performance and bypass configured CPU time limits for Sieve scripts. Install fixed version, or alternatively prevent direct access to Sieve scripts via ManageSieve or local access. No publicly available exploits are known.

Severity
medium
Software
Dovecot
Fixed in
2.4.4
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.43% — higher than 35% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.4

Fixed in: 2.4.4

How to fix this CVE

Upgrade Dovecot to version 2.4.4 or later to patch the Sieve script CPU time limit bypass vulnerability. If immediate patching is not possible, restrict access to the ManageSieve service and disable direct filesystem access to Sieve scripts to prevent malicious script uploads. Review your Sieve execution policies and consider implementing additional resource quotas at the system level as a temporary mitigation.

sudo dnf update dovecot dovecot-imapd dovecot-pop3d

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed Dovecot version: dovecot --version
  2. Verify ManageSieve service status: systemctl status dovecot | grep -i sieve or check /etc/dovecot/conf.d/ for sieve_* configuration directives
  3. Review Dovecot logs for excessive Sieve compilation or execution: grep -i 'sieve' /var/log/dovecot/dovecot.log | grep -E '(cpu|timeout|limit)'
  4. Confirm patch installation: dovecot --version should report 2.4.4 or higher; cross-reference with dpkg -l dovecot-core (Debian/Ubuntu) or rpm -qa dovecot (RHEL/CentOS)

FAQ

What is CVE-2026-40016?

CVE-2026-40016 is a resource exhaustion vulnerability in Dovecot's Sieve script engine that allows authenticated attackers to craft malicious scripts exceeding configured CPU time limits by up to 130 times, potentially degrading mail server performance.

Is CVE-2026-40016 being actively exploited?

No, this vulnerability is not currently listed on the CISA KEV catalog and no public exploits are known. However, it poses a significant denial-of-service risk and should be patched proactively.

What versions of Dovecot are affected by CVE-2026-40016?

All Dovecot versions prior to and including 2.4.3 are vulnerable. Dovecot 2.4.4 and later versions contain the fix.

How do I check if my server is vulnerable to CVE-2026-40016?

Run 'dovecot --version' and compare the output to version 2.4.4. If your version is 2.4.3 or earlier, your system is vulnerable. Additionally, check if ManageSieve is enabled in /etc/dovecot/conf.d/20-managesieve.conf.

Does Defensia detect CVE-2026-40016?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Dovecot is installed on a monitored server, CVE-2026-40016 will appear in your dashboard with remediation steps.

Related Dovecot CVEs

CVE-2026-73208CVSS 9An attacker that holds a token intended for a different purpose can authenticate, because when an OAuth2 token response does not contain a scope claim, the audience claim is used in its place and checked against the configured required scopes. These are different concepts, and the audience claim does not describe what a token is allowed to do. A token that grants no relevant permissions can be accepted because its intended recipient value happens to match a configured scope name, granting access that should have been denied. It also hides an identity provider misconfiguration where scopes are not being issued at all. Ensure the identity provider issues a scope claim for all tokens used with Dovecot, and that configured scope names do not match audience values. Update to non-vulnerable version. No publicly available exploits are known.
CVE-2026-40018CVSS 9None None None No publicly available exploits are known.
CVE-2026-40019CVSS 9An unauthenticated attacker can send a truncated quoted argument to the ManageSieve login process, which makes it spin in an infinite loop consuming CPU. This can cause degradation or denial of service for Sieve script management, and repeated connections can consume all available CPU on the server. Monitor system for abnormal CPU usage and kill the offending process. Restrict network access to the ManageSieve service to trusted clients. Update to non-vulnerable version. No publicly available exploits are known.
CVE-2026-33605CVSS 9An unauthenticated attacker can crash the ManageSieve login process by sending a small malformed command before authenticating. If running in high-security mode (default for community releases), only the attacker's own connection is terminated. If running in high-performance mode (default for Pro releases), all connections handled by the same managesieve-login process are terminated. Repeating the attack can cause denial of service for Sieve script management. Restrict network access to the ManageSieve service to trusted clients. Update to non-vulnerable version. No publicly available exploits are known.
CVE-2026-27852CVSS 9An attacker that can send mail to a user can craft a message whose headers contain a very large number of email addresses or MIME parameters, which causes excessive memory usage when the message is later parsed. The message is still delivered, but reading it over IMAP can exhaust the memory limit of the process and terminate it, causing denial of service for the affected user. Update to non-vulnerable version. No publicly available exploits are known.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-40016. Free for 1 server.

Get started free