CVE-2026-40013·Dovecot vulnerability
An attacker that has valid credentials can submit a Sieve script containing an extreme numeric literal, which causes an out-of-bounds write when the ManageSieve service compiles the script. This causes memory corruption and an observed crash of the ManageSieve process, resulting in denial of service for script management. This might be able to be used for remote code execution. Disable the ManageSieve service if users do not need remote Sieve script management. Update to non-vulnerable version. No publicly available exploits are known.
- Severity
- high
- Software
- Dovecot
- Fixed in
- 1:2.4.1+dfsg1-6+deb13u7
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.87% — higher than 57% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-40013 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.87%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
Until: 1:2.4.1+dfsg1-6+deb13u7
Fixed in: 1:2.4.1+dfsg1-6+deb13u7
How to fix this CVE
Organizations running Dovecot should update to version 1:2.4.1+dfsg1-6+deb13u7 or later to patch a memory corruption vulnerability in the ManageSieve service. The vulnerability allows authenticated attackers to trigger an out-of-bounds write through malformed Sieve scripts, leading to service crashes and potential code execution. If ManageSieve functionality is not required, disabling the service provides immediate protection while patches are staged.
sudo dnf update dovecot --refresh && sudo systemctl restart dovecotDefensia detects this vulnerability
How to check if you are affected
- Run 'dovecot --version' to check the installed Dovecot version; versions prior to 1:2.4.1+dfsg1-6+deb13u7 are vulnerable
- Verify ManageSieve is enabled by checking if port 4190 is listening: 'sudo ss -tlnp | grep 4190' or 'sudo netstat -tlnp | grep 4190'
- Search Dovecot logs for ManageSieve process crashes: 'grep -i "managesieve" /var/log/dovecot/dovecot.log | grep -i "crash\|segfault\|error"'
- Confirm the patch was applied by running 'dovecot --version' again and verifying the version matches or exceeds 1:2.4.1+dfsg1-6+deb13u7
FAQ
What is CVE-2026-40013?
CVE-2026-40013 is a memory corruption vulnerability in Dovecot's ManageSieve service that occurs when processing Sieve scripts with extreme numeric literals. Authenticated users can exploit this flaw to crash the ManageSieve process and potentially achieve remote code execution.
Is CVE-2026-40013 being actively exploited?
No, CVE-2026-40013 is not listed on the CISA Known Exploited Vulnerabilities catalog and no public exploits are currently available, though the attack requires valid user credentials.
What versions of Dovecot are affected by CVE-2026-40013?
All Dovecot versions prior to 1:2.4.1+dfsg1-6+deb13u7 are affected. The vulnerability is fixed in version 1:2.4.1+dfsg1-6+deb13u7 and later.
How do I check if my server is vulnerable to CVE-2026-40013?
Run 'dovecot --version' and compare the output to version 1:2.4.1+dfsg1-6+deb13u7; if your version is lower, your server is vulnerable. Additionally check that ManageSieve is enabled with 'sudo ss -tlnp | grep 4190'.
Does Defensia detect CVE-2026-40013?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Dovecot is installed on a monitored server, CVE-2026-40013 will appear in your dashboard with remediation steps.
Related Dovecot CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-40013. Free for 1 server.
Get started free