CVE-2026-33606·Dovecot vulnerability
Mail content stored by a user can be crafted so that it is interpreted as dsync protocol commands when an administrator later runs dsync with the stream protocol, for example during a migration. Injected commands can modify mailbox state on the destination during migration or replication, including internal mailbox attributes that a user should not be able to set directly. It can also cause dsync errors. Avoid running dsync with the stream protocol on mailboxes with untrusted content. Update to non-vulnerable version. No publicly available exploits are known.
- Severity
- high
- Software
- Dovecot
- Fixed in
- 1:2.4.1+dfsg1-6+deb13u7
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.25% — higher than 14% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Read the two together. CVE-2026-33606 scores 7.5 on CVSS, so a successful attack would be serious — but at 0.25%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.
Affected versions
Until: 1:2.4.1+dfsg1-6+deb13u7
Fixed in: 1:2.4.1+dfsg1-6+deb13u7
How to fix this CVE
Dovecot administrators should update to version 1:2.4.1+dfsg1-6+deb13u7 or later to eliminate the dsync protocol injection vulnerability. This vulnerability allows attackers to craft malicious mail content that executes as dsync commands during migration or replication operations, potentially compromising mailbox integrity. Immediately patch all Dovecot installations and avoid running dsync operations on mailboxes containing untrusted content until patching is complete.
sudo dnf install dovecot dovecot-pigeonhole && sudo systemctl restart dovecotDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check installed Dovecot version with: dovecot --version
- Step 2: Confirm if dsync is enabled and configured for stream protocol: grep -r 'dsync' /etc/dovecot/ | grep -i stream
- Step 3: Search Dovecot logs for dsync errors or unexpected mailbox state changes: grep -i 'dsync' /var/log/dovecot/dovecot.log | grep -E '(error|failed|invalid)'
- Step 4: Verify the patch by running: dpkg -l | grep dovecot and confirming version is 1:2.4.1+dfsg1-6+deb13u7 or higher
FAQ
What is CVE-2026-33606?
CVE-2026-33606 is a mail content injection vulnerability in Dovecot that allows attackers to embed dsync protocol commands within email messages, which are then executed during administrative migration or replication tasks, potentially altering mailbox state and internal attributes.
Is CVE-2026-33606 being actively exploited?
No, CVE-2026-33606 is not currently listed on the CISA KEV catalog and no public exploits are documented. However, the vulnerability requires deliberate administrative action (running dsync with stream protocol), making it primarily a risk in migration scenarios.
What versions of Dovecot are affected by CVE-2026-33606?
All Dovecot versions prior to 1:2.4.1+dfsg1-6+deb13u7 are affected. The vulnerability exists in all versions up to and including 1:2.4.1+dfsg1-6+deb13u6 on Debian-based systems.
How do I check if my server is vulnerable to CVE-2026-33606?
Run: dovecot --version and compare the output to 1:2.4.1+dfsg1-6+deb13u7. If your version is lower, your system is vulnerable. Additionally, check if dsync is configured: dovecot -c /etc/dovecot/dovecot.conf -a
Does Defensia detect CVE-2026-33606?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Dovecot is installed on a monitored server, CVE-2026-33606 will appear in your dashboard with remediation steps.
Related Dovecot CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-33606. Free for 1 server.
Get started free