medium CVSS 6.8 EPSS 0.23%

CVE-2026-33603·Dovecot vulnerability

Attacker can use a specially crafted base64 exchange between Dovecot and Client to fake SCRAM TLS channel binding. This requires that the attacker is able to position itself between Dovecot and the client connection. If successful, the attacker can eavesdrop communications between Dovecot and client as MITM proxy. Install fixed version. No publicly available exploits are known.

Severity
medium
Software
Dovecot
Fixed in
2.4.4
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.23% — higher than 13% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 2.4.4

Fixed in: 2.4.4

How to fix this CVE

Update Dovecot to version 2.4.4 or later to patch the SCRAM TLS channel binding validation flaw. This vulnerability allows attackers on the same network segment to intercept and proxy mail client connections. Apply the update immediately if your mail server is accessible from untrusted network segments, and verify the fix by checking the running version post-deployment.

sudo dnf update dovecot dovecot-imapd dovecot-pop3d

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check Dovecot version with: dovecot --version | head -1 or dpkg -l | grep dovecot (Debian/Ubuntu) / rpm -qa | grep dovecot (RHEL/CentOS)
  2. Step 2: Verify SCRAM authentication is enabled in your Dovecot configuration: grep -i 'scram' /etc/dovecot/conf.d/* to identify if SCRAM-SHA-256 or similar mechanisms are configured
  3. Step 3: Review Dovecot authentication logs for suspicious SCRAM exchange patterns: grep -i 'scram\|tls' /var/log/dovecot/auth.log or journalctl -u dovecot -u dovecot-auth | grep -i scram
  4. Step 4: After applying the patch, confirm the updated version is running: systemctl restart dovecot && dovecot --version and verify no authentication errors appear in logs

FAQ

What is CVE-2026-33603?

CVE-2026-33603 is a flaw in Dovecot's SCRAM authentication mechanism where an attacker positioned between the client and server can manipulate base64-encoded channel binding data, bypassing TLS integrity verification and establishing a man-in-the-middle proxy to eavesdrop on mail traffic.

Is CVE-2026-33603 being actively exploited?

No, there are currently no public exploits or reports of active exploitation in the wild. However, the attack requires network-level access (ARP spoofing, DNS hijacking, or compromised network infrastructure), making it a realistic threat in shared hosting or corporate environments.

What versions of Dovecot are affected by CVE-2026-33603?

All Dovecot versions prior to 2.4.4 are affected. The vulnerability has been patched in version 2.4.4 and later releases.

How do I check if my server is vulnerable to CVE-2026-33603?

Run 'dovecot --version' and compare the output to 2.4.4. If your version is lower and you have SCRAM authentication enabled (verify with 'grep mechanisms /etc/dovecot/conf.d/*'), your server is vulnerable.

Does Defensia detect CVE-2026-33603?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Dovecot is installed on a monitored server, CVE-2026-33603 will appear in your dashboard with remediation steps.

Related Dovecot CVEs

CVE-2026-73208CVSS 9An attacker that holds a token intended for a different purpose can authenticate, because when an OAuth2 token response does not contain a scope claim, the audience claim is used in its place and checked against the configured required scopes. These are different concepts, and the audience claim does not describe what a token is allowed to do. A token that grants no relevant permissions can be accepted because its intended recipient value happens to match a configured scope name, granting access that should have been denied. It also hides an identity provider misconfiguration where scopes are not being issued at all. Ensure the identity provider issues a scope claim for all tokens used with Dovecot, and that configured scope names do not match audience values. Update to non-vulnerable version. No publicly available exploits are known.
CVE-2026-40018CVSS 9None None None No publicly available exploits are known.
CVE-2026-40019CVSS 9An unauthenticated attacker can send a truncated quoted argument to the ManageSieve login process, which makes it spin in an infinite loop consuming CPU. This can cause degradation or denial of service for Sieve script management, and repeated connections can consume all available CPU on the server. Monitor system for abnormal CPU usage and kill the offending process. Restrict network access to the ManageSieve service to trusted clients. Update to non-vulnerable version. No publicly available exploits are known.
CVE-2026-33605CVSS 9An unauthenticated attacker can crash the ManageSieve login process by sending a small malformed command before authenticating. If running in high-security mode (default for community releases), only the attacker's own connection is terminated. If running in high-performance mode (default for Pro releases), all connections handled by the same managesieve-login process are terminated. Repeating the attack can cause denial of service for Sieve script management. Restrict network access to the ManageSieve service to trusted clients. Update to non-vulnerable version. No publicly available exploits are known.
CVE-2026-27852CVSS 9An attacker that can send mail to a user can craft a message whose headers contain a very large number of email addresses or MIME parameters, which causes excessive memory usage when the message is later parsed. The message is still delivered, but reading it over IMAP can exhaust the memory limit of the process and terminate it, causing denial of service for the affected user. Update to non-vulnerable version. No publicly available exploits are known.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-33603. Free for 1 server.

Get started free