CVE-2026-26081·HAProxy vulnerability
HAProxy Community Edition 3.0 through 3.3 before 3.3.3 lacks a length check for the NEW_TOKEN format. HAProxy Enterprise and ALOHA are also affected.
- Severity
- medium
- Software
- HAProxy
- Fixed in
- 3.3.3
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.48% — higher than 41% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 3.3
Until: 3.3.3
Fixed in: 3.3.3
How to fix this CVE
Upgrade HAProxy to version 3.3.3 or later to address a token format validation weakness that could allow integrity or availability degradation. Organizations running HAProxy 3.0 through 3.3.2 should prioritize this update as part of routine security maintenance. The fix implements proper length validation for the NEW_TOKEN format to prevent malformed input from bypassing security checks.
sudo dnf check-update haproxy && sudo dnf upgrade haproxyDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check your HAProxy version with 'haproxy -v' and verify if it falls within 3.0 to 3.3.2 range
- Step 2: Search HAProxy configuration files for NEW_TOKEN directives: grep -r 'NEW_TOKEN' /etc/haproxy/
- Step 3: Review HAProxy error logs for token validation failures: grep -i 'token' /var/log/haproxy.log | grep -i 'error\|invalid\|malformed'
- Step 4: After updating, confirm the new version: haproxy -v and verify it shows 3.3.3 or higher
FAQ
What is CVE-2026-26081?
This vulnerability is a missing input validation check in HAProxy's NEW_TOKEN format handler that could permit attackers to craft oversized or malformed tokens, potentially leading to service disruption or data integrity issues.
Is CVE-2026-26081 being actively exploited?
No, this vulnerability is not listed in the CISA KEV catalog and no public exploits are currently available, though organizations should still update proactively.
What versions of HAProxy are affected by CVE-2026-26081?
HAProxy Community Edition versions 3.0 through 3.3.2, and corresponding versions of HAProxy Enterprise and ALOHA products are affected.
How do I check if my server is vulnerable to CVE-2026-26081?
Run 'haproxy -v' and check if the version is between 3.0 and 3.3.2 (inclusive). If so, your installation is vulnerable and requires updating to 3.3.3 or later.
Does Defensia detect CVE-2026-26081?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If HAProxy is installed on a monitored server, CVE-2026-26081 will appear in your dashboard with remediation steps.
Related HAProxy CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-26081. Free for 1 server.
Get started free