critical CVSS 9.9 EPSS 0.23%

CVE-2026-24848·PHP vulnerability

OpenEMR is a free and open source electronic health records and medical practice management application. In 7.0.4 and earlier, the disposeDocument() method in EtherFaxActions.php allows authenticated users to write arbitrary content to arbitrary locations on the server filesystem. This vulnerability can be exploited to achieve Remote Code Execution (RCE) by uploading malicious PHP web shells.

Severity
critical
Software
PHP
Fixed in
7.0.4
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.23% — higher than 46% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-24848 scores 9.9 on CVSS, so a successful attack would be serious — but at 0.23%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 7.0.4

Fixed in: 7.0.4

How to fix this CVE

Update PHP to version 7.0.5 or later to patch the arbitrary file write vulnerability in the disposeDocument() method. This critical flaw allows authenticated users to upload malicious PHP scripts to arbitrary filesystem locations, leading to remote code execution. Ensure all OpenEMR installations are upgraded immediately and verify file permissions restrict web-writable directories.

sudo dnf update php

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

POST.*EtherFaxActions\.php.*disposeDocument|File write to [^/]*\.php in non-standard directories|Unexpected PHP files created in /tmp|/var/tmp|upload directories with timestamps correlating to suspicious POST requests

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Block or restrict POST requests to EtherFaxActions.php endpoints unless from trusted internal IPs. Implement file upload restrictions to prevent PHP files from being written outside designated directories. Use ModSecurity rules to detect attempts to write executable files via web requests.

How to check if you are affected

  1. Run `php -v` to check the installed PHP version and confirm it is 7.0.5 or later
  2. Verify OpenEMR version by checking the version.php file or admin dashboard; ensure installation is not on 7.0.4 or earlier
  3. Search web server logs for POST requests to EtherFaxActions.php with disposeDocument() calls: `grep -i 'disposedocument' /var/log/apache2/access.log /var/log/nginx/access.log`
  4. Verify the fix by checking file modification times in upload directories and confirming no unexpected PHP files exist in unexpected locations with `find / -name '*.php' -type f -newermt '2024-01-01' 2>/dev/null`

FAQ

What is CVE-2026-24848?

CVE-2026-24848 is a critical arbitrary file write vulnerability in PHP versions 7.0.4 and earlier that allows authenticated users to upload malicious PHP code to any filesystem location, enabling remote code execution on the server.

Is CVE-2026-24848 being actively exploited?

No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities catalog and no public exploits are available, though the high severity warrants immediate patching.

What versions of PHP are affected by CVE-2026-24848?

PHP versions up to and including 7.0.4 are affected. The vulnerability is resolved in PHP 7.0.5 and later versions.

How do I check if my server is vulnerable to CVE-2026-24848?

Run `php -v` to verify your version. If the output shows 7.0.4 or earlier, your system is vulnerable and requires immediate update to 7.0.5 or newer.

Does Defensia detect CVE-2026-24848?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PHP is installed on a monitored server, CVE-2026-24848 will appear in your dashboard with remediation steps.

Related PHP CVEs

CVE-2024-5932CVSS 10The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.14.1 via deserialization of untrusted input from the 'give_title' parameter. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code remotely, and to delete arbitrary files.
CVE-2025-25174CVSS 10Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in beeteam368 BeeTeam368 Extensions beeteam368-extensions allows PHP Local File Inclusion.This issue affects BeeTeam368 Extensions: from n/a through <= 1.9.4.
CVE-2025-62521CVSS 10ChurchCRM is an open-source church management system. Prior to version 5.21.0, a pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The vulnerability exists in `setup/routes/setup.php` where user input from the setup form is directly concatenated into a PHP configuration template without any validation or sanitization. Any parameter in the setup form can be used to inject PHP code that gets written to `Include/Config.php`, which is then executed on every page load. This is more severe than typical authenticated RCE vulnerabilities because it requires no credentials and affects the installation process that administrators must complete. Version 5.21.0 patches the issue.
CVE-2026-28289CVSS 10FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. A patch bypass vulnerability for CVE-2026-27636 in FreeScout 1.8.206 and earlier allows any authenticated user with file upload permissions to achieve Remote Code Execution (RCE) on the server by uploading a malicious .htaccess file using a zero-width space character prefix to bypass the security check. The vulnerability exists in the sanitizeUploadedFileName() function in app/Http/Helper.php. The function contains a Time-of-Check to Time-of-Use (TOCTOU) flaw where the dot-prefix check occurs before sanitization removes invisible characters. This vulnerability is fixed in 1.8.207.
CVE-2026-39337CVSS 10ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-24848. Free for 1 server.

Get started free