critical CVSS 9.9 EPSS 0.39%

CVE-2026-24740·Docker vulnerability

Dozzle is a realtime log viewer for docker containers. Prior to version 9.0.3, a flaw in Dozzle’s agent-backed shell endpoints allows a user restricted by label filters (for example, `label=env=dev`) to obtain an interactive root shell in out‑of‑scope containers (for example, `env=prod`) on the same agent host by directly targeting their container IDs. Version 9.0.3 contains a patch for the issue.

Severity
critical
Software
Docker
Fixed in
9.0.3
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.39% — higher than 31% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-24740 scores 9.9 on CVSS, so a successful attack would be serious — but at 0.39%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 9.0.3

Fixed in: 9.0.3

How to fix this CVE

Update Docker and Dozzle to version 9.0.3 or later to patch a critical authorization bypass in Dozzle's shell endpoints. This vulnerability allows users with restricted label-based access to escalate privileges and gain root shell access to containers outside their intended scope. Immediate patching is required to prevent unauthorized container access and potential lateral movement within multi-tenant Docker environments.

sudo dnf upgrade -y docker-ce

Defensia detects this vulnerability

How to check if you are affected

  1. Run `docker --version` and `dozzle --version` (if installed separately) to identify the current version; versions prior to 9.0.3 are vulnerable
  2. Check if Dozzle is deployed by inspecting running containers: `docker ps | grep dozzle`
  3. Review Dozzle configuration for label-based access controls in the deployment manifest or docker-compose file
  4. After patching, verify the fix: confirm `docker --version` shows the latest build and restart Dozzle container with `docker restart <dozzle_container_id>`

FAQ

What is CVE-2026-24740?

CVE-2026-24740 is a critical authorization bypass flaw in Dozzle (Docker log viewer) that allows users with restricted label-based access filters to bypass security controls and obtain interactive root shell access to containers outside their permitted scope by directly referencing container IDs.

Is CVE-2026-24740 being actively exploited?

No, this vulnerability is not currently listed on the CISA KEV catalog and has no known public exploits, though the critical CVSS score of 9.9 warrants urgent patching.

What versions of Docker are affected by CVE-2026-24740?

Dozzle versions prior to 9.0.3 are vulnerable. The affected version range extends from early releases up to and including 9.0.2.

How do I check if my server is vulnerable to CVE-2026-24740?

Run `dozzle --version` or inspect the Dozzle container image tag with `docker inspect <dozzle_container_id> | grep -i version`. If the version is below 9.0.3, your deployment is vulnerable.

Does Defensia detect CVE-2026-24740?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Docker/Dozzle is installed on a monitored server, CVE-2026-24740 will appear in your dashboard with remediation steps.

Related Docker CVEs

CVE-2026-40281CVSS 10Gotenberg is a Docker-powered stateless API for PDF files. In versions 8.30.1 and earlier, the metadata write endpoint validates metadata keys for control characters but leaves metadata values unsanitized. A newline character in a metadata value splits the ExifTool stdin line into two separate arguments, allowing injection of arbitrary ExifTool pseudo-tags such as -FileName, -Directory, -SymLink, and -HardLink. This is a bypass of the incomplete key-sanitization fix introduced in v8.30.1. An unauthenticated attacker can rename or move any PDF being processed to an arbitrary path in the container filesystem, overwrite arbitrary files, or create symlinks and hard links at arbitrary paths.
CVE-2026-33587CVSS 10Lack of user input sanitisation in Open Notebook v1.8.3 allows the application user to execute Python code (and subsequently OS commands) on the docker container via Server-Side Template Injection (SSTI) for user-created transformations.
CVE-2026-57572CVSS 10Crawl4AI is an open-source LLM-friendly web crawler and scraper. Prior to 0.9.0, the Docker API server accepted request-supplied browser_config.extra_args, which flowed into Chromium's launch arguments. An attacker could inject Chromium switches that replace a child-process launch command together with --no-zygote, causing Chromium to fork or exec an attacker-controlled command as the container's runtime user. The Docker API is unauthenticated by default, so a single request yields arbitrary command execution. This issue is fixed in version 0.9.0.
CVE-2026-42298CVSS 10Postiz is an AI social media scheduling tool. Prior to commit da44801, a "Pwn Request" vulnerability in the Build and Publish PR Docker Image workflow (.github/workflows/pr-docker-build.yml) allows any unauthenticated user to execute arbitrary code during the Docker build process and exfiltrate a highly privileged GITHUB_TOKEN (write-all permissions). This can be achieved simply by opening a Pull Request from a fork with a maliciously modified Dockerfile.dev. This issue has been patched via commit da44801.
CVE-2026-26216CVSS 10Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing unauthenticated remote attackers to import arbitrary modules and execute system commands. Successful exploitation allows full server compromise, including arbitrary command execution, file read and write access, sensitive data exfiltration, and lateral movement within internal networks.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-24740. Free for 1 server.

Get started free