CVE-2026-14663·PostgreSQL vulnerability
Cleartext storage in PostgreSQL pgcrypto disabled ciphers allows a user to recover cleartext, via direct observation of the faulty ciphertext. The OpenSSL version and OpenSSL configuration determine the disabled ciphers. If the application accepts encrypted data as input, decryption will succeed even with the wrong key. This in turn loses the modest protection from the Modification Detection Code (MDC). Affected functions are pgp_sym_encrypt, pgp_sym_decrypt, pgp_pub_encrypt, pgp_pub_decrypt, pgp_sym_encrypt_bytea, pgp_sym_decrypt_bytea, pgp_pub_encrypt_bytea, and pgp_pub_decrypt_bytea. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
- Severity
- medium
- Software
- PostgreSQL
- Fixed in
- 18.5
- Published
How likely is exploitation
FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.10% — in the bottom 1% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.
Affected versions
From: 18.0
Until: 18.5
Fixed in: 18.5
How to fix this CVE
Upgrade PostgreSQL to version 18.6 or later to resolve a cryptographic weakness in the pgcrypto extension where disabled cipher algorithms may expose encrypted data. Organizations using pgp_sym_encrypt, pgp_sym_decrypt, pgp_pub_encrypt, pgp_pub_decrypt, or their bytea variants should prioritize this update to restore proper encryption integrity and modification detection.
sudo dnf update postgresql-server postgresql-contribDefensia detects this vulnerability
How to check if you are affected
- Step 1: Check PostgreSQL version with: psql --version or SELECT version();
- Step 2: Query for pgcrypto extension use: SELECT * FROM pg_extension WHERE extname = 'pgcrypto';
- Step 3: Search PostgreSQL logs for pgp_sym_encrypt or pgp_pub_encrypt function calls: grep -i 'pgp_sym_encrypt\|pgp_pub_encrypt' /var/log/postgresql/postgresql.log
- Step 4: After upgrade, confirm version with SELECT version(); and verify pgcrypto functions work without decryption errors
FAQ
What is CVE-2026-14663?
CVE-2026-14663 is a cryptographic flaw in PostgreSQL's pgcrypto extension where weak or disabled cipher algorithms fail to properly protect encrypted data, allowing potential recovery of plaintext and bypassing modification detection mechanisms.
Is CVE-2026-14663 being actively exploited?
No, CVE-2026-14663 is not listed in the CISA Known Exploited Vulnerabilities catalog and no public exploits are currently available, though the vulnerability should still be prioritized for patching.
What versions of PostgreSQL are affected by CVE-2026-14663?
PostgreSQL 18.0 through 18.5, 17.0 through 17.10, 16.0 through 16.14, 15.0 through 15.18, and 14.0 through 14.23 are affected; PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 contain the fix.
How do I check if my server is vulnerable to CVE-2026-14663?
Run SELECT version(); in psql and compare against the version ranges above; if your version is below 18.6 (or the corresponding fixed version for your branch), you are vulnerable if pgcrypto is installed.
Does Defensia detect CVE-2026-14663?
Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PostgreSQL is installed on a monitored server, CVE-2026-14663 will appear in your dashboard with remediation steps.
Related PostgreSQL CVEs
References
Track CVEs across your fleet automatically
Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-14663. Free for 1 server.
Get started free