critical CVSS 9.8 EPSS 0.33%

CVE-2025-46331·Docker vulnerability

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.8.10 to v1.3.6 (Helm chart <= openfga-0.2.28, docker <= v.1.8.10) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. This issue has been patched in version 1.8.11.

Severity
critical
Software
Docker
Fixed in
1.8.11
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.33% — higher than 24% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2025-46331 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.33%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 1.3.6

Until: 1.8.11

Fixed in: 1.8.11

How to fix this CVE

Update Docker to version 1.8.11 or later to patch the authorization bypass vulnerability in OpenFGA. This vulnerability allows attackers to bypass access controls through specially crafted Check and ListObject API calls, potentially exposing sensitive resources. Apply the update immediately across all Docker installations running affected versions.

sudo dnf update docker-ce

Defensia detects this vulnerability

How to check if you are affected

  1. Run 'docker --version' to check your current Docker version and confirm if it falls within the vulnerable range (1.3.6 to 1.8.10)
  2. Verify OpenFGA is deployed by checking 'docker ps' and looking for containers running openfga image with vulnerable tags
  3. Review API logs for unusual Check or ListObject calls with unexpected object IDs or relation queries targeting resources the requestor should not access
  4. Confirm the patch by running 'docker --version' again after update and verify the version is 1.8.11 or higher

FAQ

What is CVE-2025-46331?

This is a critical authorization bypass flaw in OpenFGA (an authorization engine used in Docker environments) that allows attackers to bypass access control checks through manipulated Check and ListObject API calls, potentially gaining unauthorized access to protected resources.

Is CVE-2025-46331 being actively exploited?

No, this vulnerability is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available, but the critical CVSS 9.8 rating warrants immediate patching.

What versions of Docker are affected by CVE-2025-46331?

Docker versions 1.3.6 through 1.8.10 are vulnerable; the Helm chart openfga-0.2.28 and earlier are also affected. Version 1.8.11 and later contain the fix.

How do I check if my server is vulnerable to CVE-2025-46331?

Run 'docker --version' and compare the output against the vulnerable range (1.3.6–1.8.10). If your version is within this range, your system is vulnerable and requires immediate update.

Does Defensia detect CVE-2025-46331?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Docker is installed on a monitored server, CVE-2025-46331 will appear in your dashboard with remediation steps.

Related Docker CVEs

CVE-2026-33587CVSS 10Lack of user input sanitisation in Open Notebook v1.8.3 allows the application user to execute Python code (and subsequently OS commands) on the docker container via Server-Side Template Injection (SSTI) for user-created transformations.
CVE-2026-26216CVSS 10Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing unauthenticated remote attackers to import arbitrary modules and execute system commands. Successful exploitation allows full server compromise, including arbitrary command execution, file read and write access, sensitive data exfiltration, and lateral movement within internal networks.
CVE-2026-44329CVSS 10free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's SMF mounts the UPI management route group without OAuth2/bearer-token authorization middleware. A network attacker who can reach SMF on the SBI can hit UPI endpoints with no Authorization header at all, and the requests reach the SMF business handlers. In the running Docker lab this was directly demonstrated for read (GET /upi/v1/upNodesLinks), write (POST /upi/v1/upNodesLinks with attacker-controlled UP-node and link payload), and delete (DELETE /upi/v1/upNodesLinks/{nodeID}) operations. This vulnerability is fixed in 4.2.2.
CVE-2026-44181CVSS 10Jupyter Enterprise Gateway launches remote Jupyter Notebook kernels across distributed clusters like Apache Spark, Kubernetes, and Docker Swarm. In versions 2.0.0rc2 and above, prior to 3.3.0, the environment variables (KERNEL_XXX) used during the rendering of the Kubernetes manifest are vulnerable to Server Side Template Injection (SSTI). By including Jinja2 template expressions it is possible to execution Python code and OS Commands in the Enterprise Gateway service. The code can use or steal the Kubernetes service account token, which can steal Kubernetes secrets and be used to fully compromise the Kubernetes cluster by scheduling a privileged pod or a pod with a hostPath volume mount. This issue has been fixed in version 3.3.0.
CVE-2026-40281CVSS 10Gotenberg is a Docker-powered stateless API for PDF files. In versions 8.30.1 and earlier, the metadata write endpoint validates metadata keys for control characters but leaves metadata values unsanitized. A newline character in a metadata value splits the ExifTool stdin line into two separate arguments, allowing injection of arbitrary ExifTool pseudo-tags such as -FileName, -Directory, -SymLink, and -HardLink. This is a bypass of the incomplete key-sanitization fix introduced in v8.30.1. An unauthenticated attacker can rename or move any PDF being processed to an arbitrary path in the container filesystem, overwrite arbitrary files, or create symlinks and hard links at arbitrary paths.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-46331. Free for 1 server.

Get started free