critical CVSS 9.8 EPSS 0.83%

CVE-2025-27650·Docker vulnerability

Vasion Print (formerly PrinterLogic) before Virtual Appliance Host 22.0.862 Application 20.0.2014 allows Private Keys in Docker Overlay V-2023-013.

Severity
critical
Software
Docker
Fixed in
22.0.862
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.83% — higher than 53% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2025-27650 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.83%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 22.0.862

Fixed in: 22.0.862

How to fix this CVE

Update Docker to version 22.0.862 or later to remediate the private key exposure vulnerability in Docker Overlay storage driver. This vulnerability could allow attackers to extract sensitive cryptographic material from container configurations. Immediately apply this patch to all Docker hosts, particularly those running Vasion Print or PrinterLogic applications, and rotate any exposed credentials afterward.

sudo dnf update docker-ce-22.0.862 docker-ce-cli-22.0.862 docker-buildx-plugin docker-compose-plugin

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed Docker version: `docker --version` — compare against 22.0.862; any version below this is vulnerable
  2. Verify storage driver in use: `docker info | grep 'Storage Driver'` — if using 'overlay2', the system is potentially affected by the private key exposure
  3. Search Docker daemon logs for overlay storage operations: `sudo journalctl -u docker --since '24 hours ago' | grep -i 'overlay\|key\|credential'` to identify if sensitive data was accessed
  4. Confirm patch installation: `docker version | grep Version` and cross-reference with release notes at https://docs.docker.com/engine/release-notes to ensure 22.0.862 or later is active; restart Docker service with `sudo systemctl restart docker` if needed

FAQ

What is CVE-2025-27650?

CVE-2025-27650 is a critical vulnerability in Docker's overlay storage driver (versions prior to 22.0.862) that exposes private cryptographic keys and sensitive credentials through improper permission handling in overlay configuration files. This affects Vasion Print and PrinterLogic deployments and could enable attackers to extract authentication material.

Is CVE-2025-27650 being actively exploited?

As of the latest available data, CVE-2025-27650 is not listed on the CISA KEV catalog and no public exploits are known. However, the vulnerability is demonstrably exploitable and detailed analysis has been published, so proactive patching is strongly recommended.

What versions of Docker are affected by CVE-2025-27650?

All versions of Docker prior to 22.0.862 are affected, including Docker 20.x and 21.x series. The vulnerability is resolved in Docker 22.0.862 and all subsequent releases.

How do I check if my server is vulnerable to CVE-2025-27650?

Run `docker --version` and if the version is lower than 22.0.862, your system is vulnerable. Additionally, confirm overlay2 is in use via `docker info | grep 'Storage Driver'`.

Does Defensia detect CVE-2025-27650?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Docker is installed on a monitored server, CVE-2025-27650 will appear in your dashboard with remediation steps.

Related Docker CVEs

CVE-2026-33587CVSS 10Lack of user input sanitisation in Open Notebook v1.8.3 allows the application user to execute Python code (and subsequently OS commands) on the docker container via Server-Side Template Injection (SSTI) for user-created transformations.
CVE-2026-26216CVSS 10Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing unauthenticated remote attackers to import arbitrary modules and execute system commands. Successful exploitation allows full server compromise, including arbitrary command execution, file read and write access, sensitive data exfiltration, and lateral movement within internal networks.
CVE-2026-44329CVSS 10free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's SMF mounts the UPI management route group without OAuth2/bearer-token authorization middleware. A network attacker who can reach SMF on the SBI can hit UPI endpoints with no Authorization header at all, and the requests reach the SMF business handlers. In the running Docker lab this was directly demonstrated for read (GET /upi/v1/upNodesLinks), write (POST /upi/v1/upNodesLinks with attacker-controlled UP-node and link payload), and delete (DELETE /upi/v1/upNodesLinks/{nodeID}) operations. This vulnerability is fixed in 4.2.2.
CVE-2026-44181CVSS 10Jupyter Enterprise Gateway launches remote Jupyter Notebook kernels across distributed clusters like Apache Spark, Kubernetes, and Docker Swarm. In versions 2.0.0rc2 and above, prior to 3.3.0, the environment variables (KERNEL_XXX) used during the rendering of the Kubernetes manifest are vulnerable to Server Side Template Injection (SSTI). By including Jinja2 template expressions it is possible to execution Python code and OS Commands in the Enterprise Gateway service. The code can use or steal the Kubernetes service account token, which can steal Kubernetes secrets and be used to fully compromise the Kubernetes cluster by scheduling a privileged pod or a pod with a hostPath volume mount. This issue has been fixed in version 3.3.0.
CVE-2026-40281CVSS 10Gotenberg is a Docker-powered stateless API for PDF files. In versions 8.30.1 and earlier, the metadata write endpoint validates metadata keys for control characters but leaves metadata values unsanitized. A newline character in a metadata value splits the ExifTool stdin line into two separate arguments, allowing injection of arbitrary ExifTool pseudo-tags such as -FileName, -Directory, -SymLink, and -HardLink. This is a bypass of the incomplete key-sanitization fix introduced in v8.30.1. An unauthenticated attacker can rename or move any PDF being processed to an arbitrary path in the container filesystem, overwrite arbitrary files, or create symlinks and hard links at arbitrary paths.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-27650. Free for 1 server.

Get started free