critical CVSS 9.8 EPSS 1.1%

CVE-2024-43404·Python vulnerability

MEGABOT is a fully customized Discord bot for learning and fun. The `/math` command and functionality of MEGABOT versions < 1.5.0 contains a remote code execution vulnerability due to a Python `eval()`. The vulnerability allows an attacker to inject Python code into the `expression` parameter when using `/math` in any Discord channel. This vulnerability impacts any discord guild utilizing MEGABOT. This vulnerability was fixed in release version 1.5.0.

Severity
critical
Software
Python
Fixed in
1.5.0
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.1% — higher than 62% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 1.5.0

Fixed in: 1.5.0

How to fix this CVE

MEGABOT users must upgrade to version 1.5.0 or later, which removes the dangerous use of Python eval() in the /math command. If you are running MEGABOT on a server, immediately update the bot to the patched version and restart it. Verify the update by checking the bot's version information in your Discord server or reviewing the deployment logs.

sudo dnf update python3

Defensia detects this vulnerability

How to check if you are affected

  1. Check MEGABOT version: Review the bot's GitHub releases page or query the bot's version command in Discord to confirm you are running version 1.5.0 or later
  2. Audit Discord channel logs: Search Discord audit logs for /math command invocations that contain suspicious characters or multi-line Python code (parentheses, imports, underscores, quotes)
  3. Review bot application logs: Check MEGABOT application logs for entries containing 'eval()', 'expression parameter', or stack traces indicating code execution errors
  4. Verify the patch: Confirm the MEGABOT installation references the fixed version by checking git tags or release version numbers in your deployment configuration

FAQ

What is CVE-2024-43404?

CVE-2024-43404 is a critical remote code execution vulnerability in MEGABOT's /math command that allows attackers to inject and execute arbitrary Python code through the expression parameter without authentication.

Is CVE-2024-43404 being actively exploited?

No, CVE-2024-43404 is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog, and no public exploits are available. However, the vulnerability's critical nature (CVSS 9.8) and ease of exploitation make proactive patching essential.

What versions of MEGABOT are affected by CVE-2024-43404?

All MEGABOT versions prior to 1.5.0 are affected. Version 1.5.0 and later contain the fix.

How do I check if my MEGABOT instance is vulnerable?

Run the /version command in your Discord server or check the bot's GitHub commit history against the fix commit 71e79e558. If you are below version 1.5.0, you are vulnerable.

Does Defensia detect CVE-2024-43404?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If MEGABOT or Python is detected on a monitored server, CVE-2024-43404 will appear in your dashboard with remediation steps if your version is outdated.

Related Python CVEs

CVE-2026-28505CVSS 10Tautulli is a Python based monitoring and tracking tool for Plex Media Server. Prior to version 2.17.0, the str_eval() function in notification_handler.py implements a sandboxed eval() for notification text templates. The sandbox attempts to restrict callable names by inspecting code.co_names of the compiled code object. However, co_names only contains names from the outer code object. When a lambda expression is used, it creates a nested code object whose attribute accesses are stored in code.co_consts, NOT in code.co_names. The sandbox never inspects nested code objects. This issue has been patched in version 2.17.0.
CVE-2026-33054CVSS 10Mesop is a Python-based UI framework that allows users to build web applications. Versions 1.2.2 and below contain a Path Traversal vulnerability that allows any user supplying an untrusted state_token through the UI stream payload to arbitrarily target files on the disk under the standard file-based runtime backend. This can result in application denial of service (via crash loops when reading non-msgpack target files as configurations), or arbitrary file manipulation. This vulnerability heavily exposes systems hosted utilizing FileStateSessionBackend. Unauthorized malicious actors could interact with arbitrary payloads overwriting or explicitly removing underlying service resources natively outside the application bounds. This issue has been fixed in version 1.2.3.
CVE-2026-25632CVSS 10EPyT-Flow is a Python package designed for the easy generation of hydraulic and water quality scenario data of water distribution networks. Prior to 0.16.1, EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files. This vulnerability is fixed in 0.16.1.
CVE-2026-34938CVSS 10PraisonAI is a multi-agent teams system. Prior to version 1.5.90, execute_code() in praisonai-agents runs attacker-controlled Python inside a three-layer sandbox that can be fully bypassed by passing a str subclass with an overridden startswith() method to the _safe_getattr wrapper, achieving arbitrary OS command execution on the host. This issue has been patched in version 1.5.90.
CVE-2026-8481CVSS 9.9IBM Langflow OSS 1.0.0 through 1.10.0 contain a critical remote code execution vulnerability in the code validation API endpoint. The POST /api/v1/validate/code endpoint accepts user-supplied Python code and executes it directly using Python's built-in exec() function without sandboxing, input validation, or privilege restrictions, enabling any authenticated user to execute arbitrary system commands with the full privileges of the Langflow server process.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-43404. Free for 1 server.

Get started free