critical CVSS 9.9 EPSS <0.1%

CVE-2026-39888·Python vulnerability

PraisonAI is a multi-agent teams system. Prior to 1.5.115, execute_code() in praisonaiagents.tools.python_tools defaults to sandbox_mode="sandbox", which runs user code in a subprocess wrapped with a restricted __builtins__ dict and an AST-based blocklist. The AST blocklist embedded inside the subprocess wrapper (blocked_attrs of python_tools.py) contains only 11 attribute names — a strict subset of the 30+ names blocked in the direct-execution path. The four attributes that form a frame-traversal chain out of the sandbox are all absent from the subprocess list (__traceback__, tb_frame, f_back, and f_builtins). Chaining these attributes through a caught exception exposes the real Python builtins dict of the subprocess wrapper frame, from which exec can be retrieved and called under a non-blocked variable name — bypassing every remaining security layer. This vulnerability is fixed in 1.5.115.

Severity
critical
Software
Python
Fixed in
1.5.115
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at <0.1% — higher than 26% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-39888 scores 9.9 on CVSS, so a successful attack would be serious — but at <0.1%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 1.5.115

Fixed in: 1.5.115

How to fix this CVE

Update PraisonAI to version 1.5.115 or later to patch the sandbox escape vulnerability in the execute_code() function. This vulnerability allows attackers with limited privileges to bypass sandbox restrictions by chaining frame attributes to access unrestricted Python builtins. Immediately upgrade affected systems and review any code that directly executes user-supplied scripts through PraisonAI agents.

sudo dnf update python3-praisonai

Defensia detects this vulnerability

How to check if you are affected

  1. Step 1: Check the installed PraisonAI version with: python3 -m pip show praisonai | grep Version
  2. Step 2: Verify if execute_code() is used in your codebase by searching for 'execute_code' and 'sandbox_mode' in Python files
  3. Step 3: Review application logs for exception stack traces containing __traceback__, tb_frame, f_back, or f_builtins attributes, which indicate exploitation attempts
  4. Step 4: After patching, confirm the update with: python3 -m pip show praisonai | grep Version and verify it is 1.5.115 or later

FAQ

What is CVE-2026-39888?

CVE-2026-39888 is a critical sandbox escape vulnerability in PraisonAI's code execution sandbox that allows authenticated users to bypass security restrictions by leveraging frame attribute chains to access unrestricted Python builtins and execute arbitrary code.

Is CVE-2026-39888 being actively exploited?

No, CVE-2026-39888 is not currently listed on the CISA Known Exploited Vulnerabilities catalog, and no public exploit code is available.

What versions of PraisonAI are affected by CVE-2026-39888?

All versions of PraisonAI prior to 1.5.115 are affected by this vulnerability.

How do I check if my server is vulnerable to CVE-2026-39888?

Run 'python3 -m pip show praisonai' and check the Version field. If it is below 1.5.115, your installation is vulnerable.

Does Defensia detect CVE-2026-39888?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If PraisonAI is installed on a monitored server, CVE-2026-39888 will appear in your dashboard with remediation steps.

Related Python CVEs

CVE-2026-34938CVSS 10PraisonAI is a multi-agent teams system. Prior to version 1.5.90, execute_code() in praisonai-agents runs attacker-controlled Python inside a three-layer sandbox that can be fully bypassed by passing a str subclass with an overridden startswith() method to the _safe_getattr wrapper, achieving arbitrary OS command execution on the host. This issue has been patched in version 1.5.90.
CVE-2026-25632CVSS 10EPyT-Flow is a Python package designed for the easy generation of hydraulic and water quality scenario data of water distribution networks. Prior to 0.16.1, EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files. This vulnerability is fixed in 0.16.1.
CVE-2026-33054CVSS 10Mesop is a Python-based UI framework that allows users to build web applications. Versions 1.2.2 and below contain a Path Traversal vulnerability that allows any user supplying an untrusted state_token through the UI stream payload to arbitrarily target files on the disk under the standard file-based runtime backend. This can result in application denial of service (via crash loops when reading non-msgpack target files as configurations), or arbitrary file manipulation. This vulnerability heavily exposes systems hosted utilizing FileStateSessionBackend. Unauthorized malicious actors could interact with arbitrary payloads overwriting or explicitly removing underlying service resources natively outside the application bounds. This issue has been fixed in version 1.2.3.
CVE-2026-28505CVSS 10Tautulli is a Python based monitoring and tracking tool for Plex Media Server. Prior to version 2.17.0, the str_eval() function in notification_handler.py implements a sandboxed eval() for notification text templates. The sandbox attempts to restrict callable names by inspecting code.co_names of the compiled code object. However, co_names only contains names from the outer code object. When a lambda expression is used, it creates a nested code object whose attribute accesses are stored in code.co_consts, NOT in code.co_names. The sandbox never inspects nested code objects. This issue has been patched in version 2.17.0.
CVE-2026-8481CVSS 9.9IBM Langflow OSS 1.0.0 through 1.10.0 contain a critical remote code execution vulnerability in the code validation API endpoint. The POST /api/v1/validate/code endpoint accepts user-supplied Python code and executes it directly using Python's built-in exec() function without sandboxing, input validation, or privilege restrictions, enabling any authenticated user to execute arbitrary system commands with the full privileges of the Langflow server process.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-39888. Free for 1 server.

Get started free