critical CVSS 9.8 EPSS <0.1%

CVE-2026-32714·Python vulnerability

SciTokens is a reference library for generating and using SciTokens. Prior to version 1.9.6, the KeyCache class in scitokens was vulnerable to SQL Injection because it used Python's str.format() to construct SQL queries with user-supplied data (such as issuer and key_id). This allowed an attacker to execute arbitrary SQL commands against the local SQLite database. This issue has been patched in version 1.9.6.

Severity
critical
Software
Python
Fixed in
1.9.6
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at <0.1% — higher than 3% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-32714 scores 9.8 on CVSS, so a successful attack would be serious — but at <0.1%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 1.9.6

Fixed in: 1.9.6

How to fix this CVE

Update the SciTokens library to version 1.9.6 or later to patch a critical SQL injection vulnerability in the KeyCache class. The vulnerability allows attackers to execute arbitrary SQL commands by manipulating issuer and key_id parameters passed to the library. Immediately apply this patch in production environments, particularly for systems using SciTokens for authentication token validation.

sudo dnf check-update python3-scitokens && sudo dnf update python3-scitokens

Defensia detects this vulnerability

What an exploitation attempt looks like

Sample log line indicative of exploitation attempts:

SELECT.*FROM.*WHERE.*(issuer|key_id).*UNION|DROP|INSERT|UPDATE|DELETE|EXEC|script

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement input validation rules that reject SQL metacharacters (UNION, SELECT, DROP, --) in any HTTP request parameters mapped to issuer or key_id fields. Use WAF rules to block requests containing SQL keywords or double-dash comment syntax in query strings or POST bodies destined for SciTokens token validation endpoints.

How to check if you are affected

  1. Check installed SciTokens version: python3 -c "import scitokens; print(scitokens.__version__)"
  2. Verify KeyCache usage in your application: grep -r "KeyCache" /path/to/your/app --include="*.py"
  3. Review application logs for SQLite database errors containing suspicious SQL syntax patterns or stack traces from scitokens.py KeyCache methods
  4. Confirm patch installation by re-running version check: python3 -c "import scitokens; print(scitokens.__version__)" and verify output is 1.9.6 or higher

FAQ

What is CVE-2026-32714?

CVE-2026-32714 is a critical SQL injection vulnerability in SciTokens' KeyCache class where user-controlled inputs (issuer and key_id) were concatenated directly into SQL queries without parameterization, allowing attackers to execute arbitrary SQL commands against the local SQLite database.

Is CVE-2026-32714 being actively exploited?

No, there are currently no reports of active exploitation in the wild and no public exploits are available, though the critical CVSS score of 9.8 warrants immediate patching.

What versions of SciTokens are affected by CVE-2026-32714?

All versions prior to 1.9.6 are vulnerable. Update to version 1.9.6 or any subsequent release to remediate the issue.

How do I check if my server is vulnerable to CVE-2026-32714?

Run python3 -c "import scitokens; print(scitokens.__version__)" and compare the version number against 1.9.6. If your version is lower, your system is vulnerable.

Does Defensia detect CVE-2026-32714?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If SciTokens is installed on a monitored server, CVE-2026-32714 will appear in your dashboard with remediation steps.

Related Python CVEs

CVE-2026-25632CVSS 10EPyT-Flow is a Python package designed for the easy generation of hydraulic and water quality scenario data of water distribution networks. Prior to 0.16.1, EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files. This vulnerability is fixed in 0.16.1.
CVE-2026-28505CVSS 10Tautulli is a Python based monitoring and tracking tool for Plex Media Server. Prior to version 2.17.0, the str_eval() function in notification_handler.py implements a sandboxed eval() for notification text templates. The sandbox attempts to restrict callable names by inspecting code.co_names of the compiled code object. However, co_names only contains names from the outer code object. When a lambda expression is used, it creates a nested code object whose attribute accesses are stored in code.co_consts, NOT in code.co_names. The sandbox never inspects nested code objects. This issue has been patched in version 2.17.0.
CVE-2026-34938CVSS 10PraisonAI is a multi-agent teams system. Prior to version 1.5.90, execute_code() in praisonai-agents runs attacker-controlled Python inside a three-layer sandbox that can be fully bypassed by passing a str subclass with an overridden startswith() method to the _safe_getattr wrapper, achieving arbitrary OS command execution on the host. This issue has been patched in version 1.5.90.
CVE-2026-33054CVSS 10Mesop is a Python-based UI framework that allows users to build web applications. Versions 1.2.2 and below contain a Path Traversal vulnerability that allows any user supplying an untrusted state_token through the UI stream payload to arbitrarily target files on the disk under the standard file-based runtime backend. This can result in application denial of service (via crash loops when reading non-msgpack target files as configurations), or arbitrary file manipulation. This vulnerability heavily exposes systems hosted utilizing FileStateSessionBackend. Unauthorized malicious actors could interact with arbitrary payloads overwriting or explicitly removing underlying service resources natively outside the application bounds. This issue has been fixed in version 1.2.3.
CVE-2026-8481CVSS 9.9IBM Langflow OSS 1.0.0 through 1.10.0 contain a critical remote code execution vulnerability in the code validation API endpoint. The POST /api/v1/validate/code endpoint accepts user-supplied Python code and executes it directly using Python's built-in exec() function without sandboxing, input validation, or privilege restrictions, enabling any authenticated user to execute arbitrary system commands with the full privileges of the Langflow server process.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-32714. Free for 1 server.

Get started free