critical CVSS 9.8 EPSS <0.1%

CVE-2026-27459·Python vulnerability

pyOpenSSL is a Python wrapper around the OpenSSL library. Starting in version 22.0.0 and prior to version 26.0.0, if a user provided callback to `set_cookie_generate_callback` returned a cookie value greater than 256 bytes, pyOpenSSL would overflow an OpenSSL provided buffer. Starting in version 26.0.0, cookie values that are too long are now rejected.

Severity
critical
Software
Python
Fixed in
26.0.0
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at <0.1% — higher than 5% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2026-27459 scores 9.8 on CVSS, so a successful attack would be serious — but at <0.1%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

From: 22.0.0

Until: 26.0.0

Fixed in: 26.0.0

How to fix this CVE

Update pyOpenSSL to version 26.0.0 or later to patch a critical buffer overflow vulnerability in cookie handling. Applications using custom cookie generation callbacks must ensure they validate cookie length before returning values. Immediately apply security updates to all Python environments where pyOpenSSL version 22.0.0–25.x is installed.

sudo dnf update python3-pyOpenSSL

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed pyOpenSSL version: python3 -c "import OpenSSL; print(OpenSSL.__version__)"
  2. List all Python packages with version info: pip3 list | grep -i openssl or python3 -m pip show pyOpenSSL
  3. Identify applications using set_cookie_generate_callback: grep -r "set_cookie_generate_callback" /path/to/application --include="*.py"
  4. Verify patched version is installed: python3 -c "import OpenSSL; assert OpenSSL.__version__ >= '26.0.0', 'Vulnerable version detected'" && echo "Patched"

FAQ

What is CVE-2026-27459?

CVE-2026-27459 is a critical buffer overflow vulnerability in pyOpenSSL versions 22.0.0 through 25.x where oversized cookie values (>256 bytes) generated by custom callback functions cause memory corruption. Version 26.0.0 implements strict validation to reject excessively long cookies.

Is CVE-2026-27459 being actively exploited?

No, this vulnerability is not listed in the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are currently available.

What versions of Python are affected by CVE-2026-27459?

The vulnerability affects pyOpenSSL versions 22.0.0 through 25.x. Python itself is not affected; the vulnerability is in the pyOpenSSL wrapper library.

How do I check if my server is vulnerable to CVE-2026-27459?

Run 'python3 -c "import OpenSSL; print(OpenSSL.__version__)"' and compare against version 26.0.0. Any version from 22.0.0–25.x that implements set_cookie_generate_callback is vulnerable.

Does Defensia detect CVE-2026-27459?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If pyOpenSSL is installed on a monitored server, CVE-2026-27459 will appear in your dashboard with remediation steps.

Related Python CVEs

CVE-2026-33054CVSS 10Mesop is a Python-based UI framework that allows users to build web applications. Versions 1.2.2 and below contain a Path Traversal vulnerability that allows any user supplying an untrusted state_token through the UI stream payload to arbitrarily target files on the disk under the standard file-based runtime backend. This can result in application denial of service (via crash loops when reading non-msgpack target files as configurations), or arbitrary file manipulation. This vulnerability heavily exposes systems hosted utilizing FileStateSessionBackend. Unauthorized malicious actors could interact with arbitrary payloads overwriting or explicitly removing underlying service resources natively outside the application bounds. This issue has been fixed in version 1.2.3.
CVE-2026-25632CVSS 10EPyT-Flow is a Python package designed for the easy generation of hydraulic and water quality scenario data of water distribution networks. Prior to 0.16.1, EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files. This vulnerability is fixed in 0.16.1.
CVE-2026-34938CVSS 10PraisonAI is a multi-agent teams system. Prior to version 1.5.90, execute_code() in praisonai-agents runs attacker-controlled Python inside a three-layer sandbox that can be fully bypassed by passing a str subclass with an overridden startswith() method to the _safe_getattr wrapper, achieving arbitrary OS command execution on the host. This issue has been patched in version 1.5.90.
CVE-2026-28505CVSS 10Tautulli is a Python based monitoring and tracking tool for Plex Media Server. Prior to version 2.17.0, the str_eval() function in notification_handler.py implements a sandboxed eval() for notification text templates. The sandbox attempts to restrict callable names by inspecting code.co_names of the compiled code object. However, co_names only contains names from the outer code object. When a lambda expression is used, it creates a nested code object whose attribute accesses are stored in code.co_consts, NOT in code.co_names. The sandbox never inspects nested code objects. This issue has been patched in version 2.17.0.
CVE-2026-39888CVSS 9.9PraisonAI is a multi-agent teams system. Prior to 1.5.115, execute_code() in praisonaiagents.tools.python_tools defaults to sandbox_mode="sandbox", which runs user code in a subprocess wrapped with a restricted __builtins__ dict and an AST-based blocklist. The AST blocklist embedded inside the subprocess wrapper (blocked_attrs of python_tools.py) contains only 11 attribute names — a strict subset of the 30+ names blocked in the direct-execution path. The four attributes that form a frame-traversal chain out of the sandbox are all absent from the subprocess list (__traceback__, tb_frame, f_back, and f_builtins). Chaining these attributes through a caught exception exposes the real Python builtins dict of the subprocess wrapper frame, from which exec can be retrieved and called under a non-blocked variable name — bypassing every remaining security layer. This vulnerability is fixed in 1.5.115.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2026-27459. Free for 1 server.

Get started free