critical CVSS 9.8 EPSS 0.42%

CVE-2025-25196·Docker vulnerability

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA < v1.8.4 (Helm chart < openfga-0.2.22, docker < v.1.8.4) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users on OpenFGA v1.8.4 or previous, specifically under the following conditions are affected by this authorization bypass vulnerability: 1. Calling Check API or ListObjects with a model that has a relation directly assignable to both public access AND userset with the same type. 2. A type bound public access tuple is assigned to an object. 3. userset tuple is not assigned to the same object. and 4. Check request's user field is a userset that has the same type as the type bound public access tuple's user type. Users are advised to upgrade to v1.8.5 which is backwards compatible. There are no known workarounds for this vulnerability.

Severity
critical
Software
Docker
Fixed in
1.8.5
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.42% — higher than 34% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2025-25196 scores 9.8 on CVSS, so a successful attack would be serious — but at 0.42%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 1.8.5

Fixed in: 1.8.5

How to fix this CVE

Update Docker to version 1.8.5 or later to remediate this authorization bypass vulnerability in OpenFGA. The vulnerability allows attackers to bypass permission checks under specific model configurations involving public access and userset relations. Ensure all Docker instances running OpenFGA are patched, as the vulnerability is backwards compatible and requires no additional configuration changes.

sudo dnf update docker-ce docker-ce-cli

Defensia detects this vulnerability

How to check if you are affected

  1. Run 'docker --version' to check the installed Docker version; versions prior to 1.8.5 are vulnerable
  2. Execute 'docker ps --filter 'label=openfga' to identify running OpenFGA containers and note their image tags
  3. Check container image digests with 'docker inspect <container_id> | grep -i digest' to verify if patches have been pulled
  4. Verify the patch by running 'docker pull openfga:v1.8.5' and comparing the digest of the running container against the latest patched image

FAQ

What is CVE-2025-25196?

CVE-2025-25196 is an authorization bypass vulnerability in OpenFGA (bundled with Docker) that allows attackers to bypass permission checks when specific conditions are met: a relation is directly assignable to both public access and userset types, a public access tuple exists, and a userset tuple does not exist on the same object.

Is CVE-2025-25196 being actively exploited?

No, CVE-2025-25196 is not listed in the CISA Known Exploited Vulnerabilities catalog and no public exploits are currently available, though the critical CVSS 9.8 score indicates organizations should prioritize patching.

What versions of Docker are affected by CVE-2025-25196?

All Docker versions shipping OpenFGA prior to v1.8.5 are affected, including Helm charts before openfga-0.2.22. The vulnerability impacts Docker installations with bundled OpenFGA components.

How do I check if my server is vulnerable to CVE-2025-25196?

Run 'docker version' and check if the OpenFGA component version is below 1.8.5; also inspect running containers with 'docker inspect <container_id>' and search for the version label or tag.

Does Defensia detect CVE-2025-25196?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Docker is installed on a monitored server, CVE-2025-25196 will appear in your dashboard with remediation steps.

Related Docker CVEs

CVE-2026-33587CVSS 10Lack of user input sanitisation in Open Notebook v1.8.3 allows the application user to execute Python code (and subsequently OS commands) on the docker container via Server-Side Template Injection (SSTI) for user-created transformations.
CVE-2026-26216CVSS 10Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing unauthenticated remote attackers to import arbitrary modules and execute system commands. Successful exploitation allows full server compromise, including arbitrary command execution, file read and write access, sensitive data exfiltration, and lateral movement within internal networks.
CVE-2026-44329CVSS 10free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's SMF mounts the UPI management route group without OAuth2/bearer-token authorization middleware. A network attacker who can reach SMF on the SBI can hit UPI endpoints with no Authorization header at all, and the requests reach the SMF business handlers. In the running Docker lab this was directly demonstrated for read (GET /upi/v1/upNodesLinks), write (POST /upi/v1/upNodesLinks with attacker-controlled UP-node and link payload), and delete (DELETE /upi/v1/upNodesLinks/{nodeID}) operations. This vulnerability is fixed in 4.2.2.
CVE-2026-44181CVSS 10Jupyter Enterprise Gateway launches remote Jupyter Notebook kernels across distributed clusters like Apache Spark, Kubernetes, and Docker Swarm. In versions 2.0.0rc2 and above, prior to 3.3.0, the environment variables (KERNEL_XXX) used during the rendering of the Kubernetes manifest are vulnerable to Server Side Template Injection (SSTI). By including Jinja2 template expressions it is possible to execution Python code and OS Commands in the Enterprise Gateway service. The code can use or steal the Kubernetes service account token, which can steal Kubernetes secrets and be used to fully compromise the Kubernetes cluster by scheduling a privileged pod or a pod with a hostPath volume mount. This issue has been fixed in version 3.3.0.
CVE-2026-40281CVSS 10Gotenberg is a Docker-powered stateless API for PDF files. In versions 8.30.1 and earlier, the metadata write endpoint validates metadata keys for control characters but leaves metadata values unsanitized. A newline character in a metadata value splits the ExifTool stdin line into two separate arguments, allowing injection of arbitrary ExifTool pseudo-tags such as -FileName, -Directory, -SymLink, and -HardLink. This is a bypass of the incomplete key-sanitization fix introduced in v8.30.1. An unauthenticated attacker can rename or move any PDF being processed to an arbitrary path in the container filesystem, overwrite arbitrary files, or create symlinks and hard links at arbitrary paths.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2025-25196. Free for 1 server.

Get started free