critical CVSS 9.8 EPSS 1.2%

CVE-2024-8696·Docker vulnerability

A remote code execution (RCE) vulnerability via crafted extension publisher-url/additional-urls could be abused by a malicious extension in Docker Desktop before 4.34.2.

Severity
critical
Software
Docker
Fixed in
4.34.2
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 1.2% — higher than 66% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 4.34.2

Fixed in: 4.34.2

How to fix this CVE

Update Docker Desktop to version 4.34.2 or later to patch a critical remote code execution flaw that could be triggered through malicious extension configurations. This vulnerability allows attackers to execute arbitrary code by crafting malicious publisher URLs or additional URLs within Docker extensions, making immediate patching essential for all Docker Desktop users.

sudo dnf update docker-ce docker-ce-cli

Defensia detects this vulnerability

How to check if you are affected

  1. Run 'docker --version' to confirm the currently installed Docker version and verify it is 4.34.2 or later
  2. Check for suspicious extension installations with 'docker extension ls' and review any unfamiliar or recently-added extensions
  3. Examine Docker Desktop logs at ~/.docker/desktop/log.txt (macOS/Linux) or %APPDATA%\Docker\log.txt (Windows) for errors related to extension URL parsing or unexpected network calls
  4. After applying the patch, re-run 'docker --version' and verify the output shows version 4.34.2 or higher to confirm the remediation was successful

FAQ

What is CVE-2024-8696?

This is a critical remote code execution vulnerability in Docker Desktop that allows attackers to execute arbitrary code by embedding malicious publisher URLs or additional URLs within Docker extensions. An attacker could craft a malicious extension that triggers code execution when loaded or interacted with.

Is CVE-2024-8696 being actively exploited?

There is no evidence of active exploitation in the wild at this time, and no public exploits have been released. However, the critical CVSS score of 9.8 warrants immediate patching regardless of current threat activity.

What versions of Docker are affected by CVE-2024-8696?

All versions of Docker Desktop before 4.34.2 are vulnerable. The vulnerability was patched in Docker Desktop 4.34.2 and later.

How do I check if my server is vulnerable to CVE-2024-8696?

Run 'docker --version' and compare the version number to 4.34.2. If your version is lower than 4.34.2, your system is vulnerable and requires immediate updating.

Does Defensia detect CVE-2024-8696?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Docker is installed on a monitored server, CVE-2024-8696 will appear in your dashboard with remediation steps.

Related Docker CVEs

CVE-2026-33587CVSS 10Lack of user input sanitisation in Open Notebook v1.8.3 allows the application user to execute Python code (and subsequently OS commands) on the docker container via Server-Side Template Injection (SSTI) for user-created transformations.
CVE-2026-26216CVSS 10Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing unauthenticated remote attackers to import arbitrary modules and execute system commands. Successful exploitation allows full server compromise, including arbitrary command execution, file read and write access, sensitive data exfiltration, and lateral movement within internal networks.
CVE-2026-44329CVSS 10free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's SMF mounts the UPI management route group without OAuth2/bearer-token authorization middleware. A network attacker who can reach SMF on the SBI can hit UPI endpoints with no Authorization header at all, and the requests reach the SMF business handlers. In the running Docker lab this was directly demonstrated for read (GET /upi/v1/upNodesLinks), write (POST /upi/v1/upNodesLinks with attacker-controlled UP-node and link payload), and delete (DELETE /upi/v1/upNodesLinks/{nodeID}) operations. This vulnerability is fixed in 4.2.2.
CVE-2026-44181CVSS 10Jupyter Enterprise Gateway launches remote Jupyter Notebook kernels across distributed clusters like Apache Spark, Kubernetes, and Docker Swarm. In versions 2.0.0rc2 and above, prior to 3.3.0, the environment variables (KERNEL_XXX) used during the rendering of the Kubernetes manifest are vulnerable to Server Side Template Injection (SSTI). By including Jinja2 template expressions it is possible to execution Python code and OS Commands in the Enterprise Gateway service. The code can use or steal the Kubernetes service account token, which can steal Kubernetes secrets and be used to fully compromise the Kubernetes cluster by scheduling a privileged pod or a pod with a hostPath volume mount. This issue has been fixed in version 3.3.0.
CVE-2026-40281CVSS 10Gotenberg is a Docker-powered stateless API for PDF files. In versions 8.30.1 and earlier, the metadata write endpoint validates metadata keys for control characters but leaves metadata values unsanitized. A newline character in a metadata value splits the ExifTool stdin line into two separate arguments, allowing injection of arbitrary ExifTool pseudo-tags such as -FileName, -Directory, -SymLink, and -HardLink. This is a bypass of the incomplete key-sanitization fix introduced in v8.30.1. An unauthenticated attacker can rename or move any PDF being processed to an arbitrary path in the container filesystem, overwrite arbitrary files, or create symlinks and hard links at arbitrary paths.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-8696. Free for 1 server.

Get started free