critical CVSS 9.8 EPSS 6.3%

CVE-2024-55964·Docker vulnerability

An issue was discovered in Appsmith before 1.52. An incorrectly configured PostgreSQL instance in the Appsmith image leads to remote command execution inside the Appsmith Docker container. The attacker must be able to access Appsmith, login to it, create a datasource, create a query against that datasource, and execute that query.

Severity
critical
Software
Docker
Fixed in
1.52
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 6.3% — in the top 7% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Affected versions

Until: 1.52

Fixed in: 1.52

How to fix this CVE

Upgrade Appsmith to version 1.52 or later to remediate a critical PostgreSQL misconfiguration flaw within Docker containers. This vulnerability allows authenticated users to execute arbitrary commands on the host system through crafted database queries. Organizations running older Appsmith versions should prioritize this update as part of their container security hardening process.

sudo dnf update docker-ce

Defensia detects this vulnerability

WAF mitigation (if patching is not yet possible)

Add this rule to your WAF to block exploitation attempts while you schedule the patch.

Implement network segmentation to restrict direct access to Appsmith instances from untrusted networks. Deploy a WAF rule to rate-limit datasource creation and query execution endpoints (POST /api/v1/datasources, POST /api/v1/queries), and require multi-factor authentication for all Appsmith user accounts to prevent unauthorized database query execution.

How to check if you are affected

  1. Step 1: Check the Appsmith version by running `docker exec <container_id> cat /opt/appsmith/package.json | grep version` or checking the UI footer for the version number
  2. Step 2: Identify exposed Appsmith instances by scanning network access logs for connections to port 80/443 and verify authentication requirements are enforced
  3. Step 3: Review PostgreSQL query logs within the Appsmith container for suspicious SQL commands containing shell metacharacters (backticks, pipes, semicolons) or system command patterns using `docker logs <container_id> | grep -i 'execute\|shell\|command'`
  4. Step 4: Verify successful remediation by confirming Appsmith version >= 1.52 via the admin dashboard or by inspecting the running container's version metadata

FAQ

What is CVE-2024-55964?

CVE-2024-55964 is a critical remote code execution vulnerability in Appsmith versions prior to 1.52, where misconfigurations in the bundled PostgreSQL database allow authenticated users to execute arbitrary system commands through crafted SQL queries executed within the Docker container.

Is CVE-2024-55964 being actively exploited?

According to CISA's Known Exploited Vulnerabilities list, CVE-2024-55964 is not currently listed as actively exploited in the wild, and no public exploit code has been disclosed.

What versions of Docker are affected by CVE-2024-55964?

Appsmith versions prior to 1.52 are vulnerable. The vulnerability exists in the Appsmith application layer within Docker containers, not in Docker itself. Any deployment running Appsmith < 1.52 in a Docker container is at risk.

How do I check if my server is vulnerable to CVE-2024-55964?

Run `docker exec <appsmith_container_id> cat /opt/appsmith/package.json | grep -oP '"version":\s*"\K[^"]+' | head -1` to determine the installed version, then compare against 1.52. If the version is lower, your deployment is vulnerable.

Does Defensia detect CVE-2024-55964?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If Appsmith is deployed in a monitored Docker environment, CVE-2024-55964 will appear in your dashboard with remediation steps and version mismatches.

Related Docker CVEs

CVE-2026-33587CVSS 10Lack of user input sanitisation in Open Notebook v1.8.3 allows the application user to execute Python code (and subsequently OS commands) on the docker container via Server-Side Template Injection (SSTI) for user-created transformations.
CVE-2026-26216CVSS 10Crawl4AI versions prior to 0.8.0 contain a remote code execution vulnerability in the Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The __import__ builtin was included in the allowed builtins, allowing unauthenticated remote attackers to import arbitrary modules and execute system commands. Successful exploitation allows full server compromise, including arbitrary command execution, file read and write access, sensitive data exfiltration, and lateral movement within internal networks.
CVE-2026-44329CVSS 10free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's SMF mounts the UPI management route group without OAuth2/bearer-token authorization middleware. A network attacker who can reach SMF on the SBI can hit UPI endpoints with no Authorization header at all, and the requests reach the SMF business handlers. In the running Docker lab this was directly demonstrated for read (GET /upi/v1/upNodesLinks), write (POST /upi/v1/upNodesLinks with attacker-controlled UP-node and link payload), and delete (DELETE /upi/v1/upNodesLinks/{nodeID}) operations. This vulnerability is fixed in 4.2.2.
CVE-2026-44181CVSS 10Jupyter Enterprise Gateway launches remote Jupyter Notebook kernels across distributed clusters like Apache Spark, Kubernetes, and Docker Swarm. In versions 2.0.0rc2 and above, prior to 3.3.0, the environment variables (KERNEL_XXX) used during the rendering of the Kubernetes manifest are vulnerable to Server Side Template Injection (SSTI). By including Jinja2 template expressions it is possible to execution Python code and OS Commands in the Enterprise Gateway service. The code can use or steal the Kubernetes service account token, which can steal Kubernetes secrets and be used to fully compromise the Kubernetes cluster by scheduling a privileged pod or a pod with a hostPath volume mount. This issue has been fixed in version 3.3.0.
CVE-2026-40281CVSS 10Gotenberg is a Docker-powered stateless API for PDF files. In versions 8.30.1 and earlier, the metadata write endpoint validates metadata keys for control characters but leaves metadata values unsanitized. A newline character in a metadata value splits the ExifTool stdin line into two separate arguments, allowing injection of arbitrary ExifTool pseudo-tags such as -FileName, -Directory, -SymLink, and -HardLink. This is a bypass of the incomplete key-sanitization fix introduced in v8.30.1. An unauthenticated attacker can rename or move any PDF being processed to an arbitrary path in the container filesystem, overwrite arbitrary files, or create symlinks and hard links at arbitrary paths.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-55964. Free for 1 server.

Get started free