high CVSS 8.8 EPSS 0.88%

CVE-2024-39935·Nginx vulnerability

jc21 NGINX Proxy Manager before 2.11.3 allows backend/internal/certificate.js OS command injection by an authenticated user (with certificate management privileges) via untrusted input to the DNS provider configuration. NOTE: this is not part of any NGINX software shipped by F5.

Severity
high
Software
Nginx
Fixed in
2.11.3
Published

How likely is exploitation

FIRST's Exploit Prediction Scoring System puts the probability of this CVE being exploited in the next 30 days at 0.88% — higher than 55% of all published CVEs. EPSS is an independent forecast of exploitation, not a severity rating: it says nothing about how much damage a successful attack does, which is what a CVSS score measures.

Read the two together. CVE-2024-39935 scores 8.8 on CVSS, so a successful attack would be serious — but at 0.88%, almost nobody is currently attempting it. That is a different situation from a flaw under mass exploitation, and it is usually the difference between patching on your next maintenance window and patching tonight.

Affected versions

Until: 2.11.3

Fixed in: 2.11.3

How to fix this CVE

Update NGINX Proxy Manager to version 2.11.3 or later to patch a critical command injection vulnerability in the certificate management module. The vulnerability allows authenticated users with certificate management privileges to execute arbitrary OS commands through malicious DNS provider configuration input. Immediate patching is recommended to prevent privilege escalation and system compromise.

sudo dnf update nginx-proxy-manager

Defensia detects this vulnerability

How to check if you are affected

  1. Check installed NGINX Proxy Manager version: dpkg -l | grep nginx-proxy-manager or rpm -qa | grep nginx-proxy-manager
  2. Verify the certificate management service is running: systemctl status nginx-proxy-manager
  3. Search logs for DNS provider configuration changes: grep -i 'dns\|certificate\|provider' /var/log/nginx-proxy-manager/*.log | grep -i 'modified\|updated\|created'
  4. Confirm patch installation by running nginx-proxy-manager --version or checking /opt/nginx-proxy-manager/package.json for version >= 2.11.3

FAQ

What is CVE-2024-39935?

CVE-2024-39935 is an OS command injection vulnerability in NGINX Proxy Manager's certificate management module that allows authenticated users with certificate privileges to execute arbitrary commands by injecting malicious payloads into DNS provider configuration fields.

Is CVE-2024-39935 being actively exploited?

No, CVE-2024-39935 is not currently listed on the CISA Known Exploited Vulnerabilities (KEV) catalog and no public exploits are available. However, the vulnerability should still be patched promptly due to its high severity (CVSS 8.8) and the authentication context in which it occurs.

What versions of NGINX Proxy Manager are affected by CVE-2024-39935?

All versions of NGINX Proxy Manager prior to version 2.11.3 are vulnerable. Version 2.11.3 and later include the security fix.

How do I check if my server is vulnerable to CVE-2024-39935?

Run 'nginx-proxy-manager --version' or 'cat /opt/nginx-proxy-manager/package.json | grep version' to determine your installed version. If the version is below 2.11.3, your system is vulnerable.

Does Defensia detect CVE-2024-39935?

Yes — Defensia's CVE advisory scanner compares installed package versions against the NVD database. If NGINX Proxy Manager is installed on a monitored server, CVE-2024-39935 will appear in your dashboard with remediation steps.

Related Nginx CVEs

CVE-2009-3555CVSS 10The TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft Internet Information Services (IIS) 7.0, mod_ssl in the Apache HTTP Server 2.2.14 and earlier, OpenSSL before 0.9.8l, GnuTLS 2.8.5 and earlier, Mozilla Network Security Services (NSS) 3.12.4 and earlier, multiple Cisco products, and other products, does not properly associate renegotiation handshakes with an existing connection, which allows man-in-the-middle attackers to insert data into HTTPS sessions, and possibly other types of sessions protected by TLS or SSL, by sending an unauthenticated request that is processed retroactively by a server in a post-renegotiation context, related to a "plaintext injection" attack, aka the "Project Mogul" issue.
CVE-2021-23017CVSS 9A security issue in nginx resolver was identified, which might allow an attacker who is able to forge UDP packets from the DNS server to cause 1-byte memory overwrite, resulting in worker process crash or potential other impact.
CVE-2023-44487CVSS 9The HTTP/2 protocol allows a denial of service (server resource consumption) because request cancellation can reset many streams quickly, as exploited in the wild in August through October 2023.
CVE-2026-42946CVSS 9A vulnerability exists in the ngx_http_scgi_module and ngx_http_uwsgi_module modules that may result in excessive memory allocation or an over-read of data. When scgi_pass or uwsgi_pass is configured, an unauthenticated attacker with man-in-the-middle (MITM) ability to control responses from an upstream server may be able to read the memory of the NGINX worker process or restart it.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
CVE-2026-60005CVSS 9NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_slice_module module. When the slice directive and unnamed regex captures are configured or when a background cache update happens, unauthenticated attackers can send requests that may cause uninitialized memory access in the NGINX worker process, leading to limited disclosure of memory or a restart. Impact: This vulnerability may allow remote, unauthenticated attackers to have limited control to disclose memory contents or restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only. Note: The ngx_http_slice_module module is not enabled by default; it's enabled with the --with-http_slice_module configuration parameter. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Track CVEs across your fleet automatically

Defensia scans your Linux servers and tells you exactly which ones are running vulnerable versions — including CVE-2024-39935. Free for 1 server.

Get started free